Forum Jump Gallery Social Groups vBLive Garage Register Now Videos Link To Us Store Site Map TSBs
Cobalt SS Network Forums
The Cobalt SS Network is the leading resource for all Chevy Cobalts and related Delta
platform cars. Registered users do not see the above ads. Please Register - It's Free!
Vendor Forums



Go Back   Cobalt SS Network > General > 08-10 SS Turbocharged General Discussion
Sign in using an external account
Register Forgot Password?

Home Regional All Albums   FAQ Members List
08-10 SS Turbocharged General Discussion Discuss the 2008 - 2009 Chevy Cobalt SS Turbocharged. On sale since the second quarter of 2008.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 07-13-2010, 01:42 AM   #1
Senior Member

Points: 14,232, Level: 77
Points: 14,232, Level: 77 Points: 14,232, Level: 77 Points: 14,232, Level: 77
Level up: 46%, 218 Points needed
Level up: 46% Level up: 46% Level up: 46%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Dart_SI's Avatar
 
Join Date: 11-15-09
Location: kansas
Member #: 51499
Posts: 7,146
Images: 5
iTrader: (1)
Send a message via AIM to Dart_SI
Check out my gallery  Check out my vbgarage 

had any problems on your 2010 SS?? (2010's only)

ive heard of plenty of things going wrong with the 08 and 09 ss/tc. i dont need to list them we all know. lol. anyway, any bad things gonig on with the 2010 ss/tc's? usually a car manufacturer improves a vehicle every year. i was wondering if the 2010 ss/tc are having less problems than the previous years.

the only problem ive had on mine so far, was that the car could not shift into 5th gear without using the reverse lockout. that was a factory defect and i got it fixed in like 20 mins. no problems since then, however i only have 3k miles on it so far. im in love with my ss, just hoping itl work right while i own it (plan on keeping it till about 60-80k miles)
__________________
Dart_SI is offline   Reply With Quote
Old 07-13-2010, 01:49 AM   #2
New Member
 
Join Date: 05-13-10
Location: Oregon
Member #: 54655
Posts: 54
iTrader: (1)
Check out my gallery  Check out my vbgarage 

Hey me Too. Car wouldn't go into 5th gear without reverse lockout. So far Nothing else. only have 1800 on the odo though.
LiveT is offline   Reply With Quote
Old 07-13-2010, 02:07 AM   #3
Senior Member

Points: 6,939, Level: 54
Points: 6,939, Level: 54 Points: 6,939, Level: 54 Points: 6,939, Level: 54
Level up: 95%, 11 Points needed
Level up: 95% Level up: 95% Level up: 95%
Activity: 1.2%
Activity: 1.2% Activity: 1.2% Activity: 1.2%

 
Join Date: 02-03-09
Location: Phoenix, Arizona
Member #: 37771
Posts: 4,871
Images: 31
iTrader: (1)
Send a message via AIM to sundevil07
Check out my gallery  Check out my vbgarage 

none yet, 2000 miles :crosses fingers:
__________________
sundevil07 is offline   Reply With Quote
Old 07-13-2010, 02:26 AM   #4
Senior Member
Points: 7,637, Level: 58
Points: 7,637, Level: 58 Points: 7,637, Level: 58 Points: 7,637, Level: 58
Level up: 44%, 113 Points needed
Level up: 44% Level up: 44% Level up: 44%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 09-30-09
Location: Los Angeles
Member #: 50610
Posts: 2,532
Images: 28
iTrader: (3)
Check out my gallery  Check out my vbgarage 

Quote:
Originally Posted by Dart_SI View Post
ive heard of plenty of things going wrong with the 08 and 09 ss/tc. i dont need to list them we all know. lol. anyway, any bad things gonig on with the 2010 ss/tc's? usually a car manufacturer improves a vehicle every year. i was wondering if the 2010 ss/tc are having less problems than the previous years.

the only problem ive had on mine so far, was that the car could not shift into 5th gear without using the reverse lockout. that was a factory defect and i got it fixed in like 20 mins. no problems since then, however i only have 3k miles on it so far. im in love with my ss, just hoping itl work right while i own it (plan on keeping it till about 60-80k miles)
How does a 2010 differ from a 2009 (or 2008 for that matter)? I'm not aware of any *mechanical* changes that have been made since the car came out in 08. Some here have said the pressure plate was beefed up for 09 models...I think that's NOT the case and no one has been able to substantiate that claim either. I bought a 2009 with 8K miles. I put on 2K since I got it..NOTHING has gone wrong *yet*. I think many of the problems you see on this board are *self induced* with mods having problems and pushing the limits with lots of NLS and launch driving. Also, many GM1 installs are giving people fits. Sure...you're going to some find problems with ANY of the new cars, I don't think the SS/TC stands out in particular as a *problem* car at all. If anyone here knows of changes (mechanical) that have been made, please chime in.
__________________
ronn is offline   Reply With Quote
Old 07-13-2010, 03:13 AM   #5
Junior Member
Points: 2,454, Level: 30
Points: 2,454, Level: 30 Points: 2,454, Level: 30 Points: 2,454, Level: 30
Level up: 3%, 146 Points needed
Level up: 3% Level up: 3% Level up: 3%
Activity: 1.0%
Activity: 1.0% Activity: 1.0% Activity: 1.0%

 
Join Date: 05-13-10
Location: florida, close to miami
Member #: 54671
Posts: 436
iTrader: (3)
Send a message via AIM to xodus Send a message via MSN to xodus
ososcamoking
Check out my gallery  Check out my vbgarage 

only problem i had was 5th gear also... i took it in to have it adjusted since i do have warranty instead of doing it myself came back 3 hours later same thing , so i did it myself, and everything has been great ever since.
__________________
H.A.T.E.R.S. Having Anger Towards Everyone Reaching Success


xodus is offline   Reply With Quote
Old 07-13-2010, 08:22 AM   #6
Senior Member
Points: 6,857, Level: 54
Points: 6,857, Level: 54 Points: 6,857, Level: 54 Points: 6,857, Level: 54
Level up: 54%, 93 Points needed
Level up: 54% Level up: 54% Level up: 54%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 09-18-07
Location: Palm Beach, FL
Member #: 20094
Posts: 820
iTrader: (10)
Send a message via AIM to RiceCop
Check out my gallery  Check out my vbgarage 

I have 7880mi on mine, no issues yet other than the sunroof that every one complains about.
__________________
U.S. and Canada Trifecta Dealer- Click HERE to get your Trifecta tune FAST

2010 Cobalt SS/TC- K&N SRI, Injen charge pipe, ZZP Catless DP, 23psi Trifecta Tune

1972 Nova- 427ci SBC, Dart heads, CompCams cam, Proform 980cfm and much more!
RiceCop is offline   Reply With Quote
Old 07-13-2010, 09:30 AM   #7
New Member
Points: 1,620, Level: 23
Points: 1,620, Level: 23 Points: 1,620, Level: 23 Points: 1,620, Level: 23
Level up: 20%, 80 Points needed
Level up: 20% Level up: 20% Level up: 20%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 06-10-09
Location: madison, wi
Member #: 47250
Posts: 9
iTrader: (0)
Check out my gallery  Check out my vbgarage 

my front left traction sensor broke at about 3k miles.
willh is offline   Reply With Quote
Old 07-13-2010, 09:37 AM   #8
Senior Member
Points: 2,797, Level: 32
Points: 2,797, Level: 32 Points: 2,797, Level: 32 Points: 2,797, Level: 32
Level up: 32%, 103 Points needed
Level up: 32% Level up: 32% Level up: 32%
Activity: 0.5%
Activity: 0.5% Activity: 0.5% Activity: 0.5%

 
Join Date: 03-30-10
Location: Queens
Member #: 53854
Posts: 878
iTrader: (0)
Check out my gallery  Check out my vbgarage 

Bought car end of march withing 3 weeks of owning the car the ecm and bcm needed to be replaced took a month to fix but now car has 6800 miles and runs fine well except that the display told me to service the rear brakes
brice240z is offline   Reply With Quote
Old 07-13-2010, 09:39 AM   #9
Senior Member

Points: 5,003, Level: 45
Points: 5,003, Level: 45 Points: 5,003, Level: 45 Points: 5,003, Level: 45
Level up: 27%, 147 Points needed
Level up: 27% Level up: 27% Level up: 27%
Activity: 0.1%
Activity: 0.1% Activity: 0.1% Activity: 0.1%

 
Join Date: 07-27-09
Location: Concord, NH
Member #: 49217
Posts: 3,730
iTrader: (1)
Check out my gallery  Check out my vbgarage 

I have 5,750 on mine and something is wrong with my fuel system or atleast thats what vince said.

My car kinda stutters/bogs at a low gear just puttin' around town, vince said he thinks it's a fuel pressure reg. or a fuel pump
__________________
Cobalt's Gone...

New Ride: 2013 Mustang GT Brembo Package
Supercharged Guy is offline   Reply With Quote
Old 07-13-2010, 10:06 AM   #10
Senior Member

Points: 13,618, Level: 75
Points: 13,618, Level: 75 Points: 13,618, Level: 75 Points: 13,618, Level: 75
Level up: 92%, 32 Points needed
Level up: 92% Level up: 92% Level up: 92%
Activity: 18.0%
Activity: 18.0% Activity: 18.0% Activity: 18.0%

 
Join Date: 04-21-09
Location: Newark, DE
Member #: 43887
Posts: 9,876
iTrader: (1)
Joe Domiano
Check out my gallery  Check out my vbgarage 

if you cant get into 5th gear, adjust the cables yourself, its easy.
__________________

-----------------------------------------------------------------------
rally yellow 2009 Cobalt SS sedan
mods: K&N SRI, CIA catted 3" stainless steel DP, ZZP charge pipe, R1Concept slotted premium rotors w/ hawk pads, TWM STS with solid shifter bushings, 35% 3M tint, 4500K fogs, projector retrofits 4500K, ZZP dual gauge pod w/ Aeroforce interceptor.
CudaJoe is offline   Reply With Quote
Old 07-13-2010, 10:14 AM   #11
Member

Points: 5,445, Level: 47
Points: 5,445, Level: 47 Points: 5,445, Level: 47 Points: 5,445, Level: 47
Level up: 48%, 105 Points needed
Level up: 48% Level up: 48% Level up: 48%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 09-10-07
Location: Ohio
Member #: 19869
Posts: 251
iTrader: (0)
Check out my gallery  Check out my vbgarage 

Hey when you hit 60k to 80k let me know maybe ill buy it lol
kyle1853 is offline   Reply With Quote
Old 07-13-2010, 02:22 PM   #12
New Member
Points: 2,680, Level: 31
Points: 2,680, Level: 31 Points: 2,680, Level: 31 Points: 2,680, Level: 31
Level up: 54%, 70 Points needed
Level up: 54% Level up: 54% Level up: 54%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 05-23-10
Location: Pottstown
Member #: 54855
Posts: 61
iTrader: (0)
Check out my gallery  Check out my vbgarage 

So far I've owned mine for 2 months and have not come across any problems.
__________________
Jacob Martinez
Pottstown, PA

2010 Cobalt SS/TC 13.97@103mph (Cecil County Dragway)
1987 Buick Regal T-Type 12.80@104 (Englishtown Raceway Park)
1973 Buick Century GS 12.77@105mph (Atco Raceway)
JaCobalt is offline   Reply With Quote
Old 07-13-2010, 02:35 PM   #13
Senior Member

Points: 5,619, Level: 48
Points: 5,619, Level: 48 Points: 5,619, Level: 48 Points: 5,619, Level: 48
Level up: 35%, 131 Points needed
Level up: 35% Level up: 35% Level up: 35%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 05-03-08
Location: Halifax Nova Scotia, Canada
Member #: 25602
Posts: 1,322
Images: 17
iTrader: (0)
Check out my gallery  Check out my vbgarage 

Quote:
Originally Posted by CudaJoe View Post
if you cant get into 5th gear, adjust the cables yourself, its easy.
what exactly is the issue with 5th ...? when i first got the car sometimes it wouldn't want to go into 5th... i chalked it up to me being a rookie on the LNF. however i still have this sometimes... if i take it out of gear move the shifter around (left and right) it will go in but sometimes takes 2 or 3 tries...
__________________
Whitty is offline   Reply With Quote
Old 07-13-2010, 04:33 PM   #14
Member

Points: 3,193, Level: 34
Points: 3,193, Level: 34 Points: 3,193, Level: 34 Points: 3,193, Level: 34
Level up: 96%, 7 Points needed
Level up: 96% Level up: 96% Level up: 96%
Activity: 1.6%
Activity: 1.6% Activity: 1.6% Activity: 1.6%

 
Join Date: 02-10-10
Location: Southern Indiana
Member #: 52999
Posts: 202
iTrader: (0)
UncagedSS
Check out my gallery  Check out my vbgarage 

I have just over 4000mi and no problems except for the usual rotor grooving issues, brakes squeeking and misc rattles. Other than that runs just like new.
(SS)eexx is offline   Reply With Quote
Old 07-13-2010, 05:27 PM   #15
Junior Member
Points: 2,454, Level: 30
Points: 2,454, Level: 30 Points: 2,454, Level: 30 Points: 2,454, Level: 30
Level up: 3%, 146 Points needed
Level up: 3% Level up: 3% Level up: 3%
Activity: 1.0%
Activity: 1.0% Activity: 1.0% Activity: 1.0%

 
Join Date: 05-13-10
Location: florida, close to miami
Member #: 54671
Posts: 436
iTrader: (3)
Send a message via AIM to xodus Send a message via MSN to xodus
ososcamoking
Check out my gallery  Check out my vbgarage 

linkage needs to be adjusted.


Quote:
Originally Posted by Whitty View Post
what exactly is the issue with 5th ...? when i first got the car sometimes it wouldn't want to go into 5th... i chalked it up to me being a rookie on the LNF. however i still have this sometimes... if i take it out of gear move the shifter around (left and right) it will go in but sometimes takes 2 or 3 tries...
__________________
H.A.T.E.R.S. Having Anger Towards Everyone Reaching Success


xodus is offline   Reply With Quote
Old 07-13-2010, 05:31 PM   #16
Senior Member

Points: 3,972, Level: 40
Points: 3,972, Level: 40 Points: 3,972, Level: 40 Points: 3,972, Level: 40
Level up: 11%, 178 Points needed
Level up: 11% Level up: 11% Level up: 11%
Activity: 2.4%
Activity: 2.4% Activity: 2.4% Activity: 2.4%

 
Join Date: 05-26-10
Location: Edinburg, Tx
Member #: 54904
Posts: 906
iTrader: (0)
D3C3PT1ON24 D3C3PT1ON24
Check out my gallery  Check out my vbgarage 

The only problem I've had is that it's not fast enough. LOL
4500 miles on the OD and not a single problem here.
__________________
ZZP ZFR Plus Goodies, Trifecta 24psi E47 tune, Stock Block and Stock Clutch
MS3 2 SSTC is offline   Reply With Quote
Old 07-13-2010, 05:36 PM   #17
Member

Points: 1,818, Level: 25
Points: 1,818, Level: 25 Points: 1,818, Level: 25 Points: 1,818, Level: 25
Level up: 18%, 82 Points needed
Level up: 18% Level up: 18% Level up: 18%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 06-24-10
Location: illinois
Member #: 55446
Posts: 368
iTrader: (0)
Check out my gallery  Check out my vbgarage 

i had a few problems my shift link broke 2 times first time got stuck in gear and wouldnt get out of gear and second one broke it during no lift shift
__________________
LittleRedRocketSS is offline   Reply With Quote
Old 07-13-2010, 09:12 PM   #18
Senior Member
Points: 7,470, Level: 57
Points: 7,470, Level: 57 Points: 7,470, Level: 57 Points: 7,470, Level: 57
Level up: 60%, 80 Points needed
Level up: 60% Level up: 60% Level up: 60%
Activity: 1.2%
Activity: 1.2% Activity: 1.2% Activity: 1.2%

 
Join Date: 09-29-05
Location: Austin, TX
Member #: 3549
Posts: 1,083
Images: 14
iTrader: (1)
Check out my gallery  Check out my vbgarage 

1,300 miles here and the only thing wrong with it is kind of an odd one. The A/C won't blow completely cold unless the temp dial is one notch above full cold. I think it needs a control head but haven't got around to putting one in it yet.

Cars -are- improved upon in some years because of all the bulletins released. An example would be the sound insulation around the high pressure fuel pump. That's factory in the later SS cars.
Malaclypse is offline   Reply With Quote
Old 07-13-2010, 10:32 PM   #19
Senior Member

Points: 4,916, Level: 44
Points: 4,916, Level: 44 Points: 4,916, Level: 44 Points: 4,916, Level: 44
Level up: 83%, 34 Points needed
Level up: 83% Level up: 83% Level up: 83%
Activity: 16.0%
Activity: 16.0% Activity: 16.0% Activity: 16.0%

 
Join Date: 01-12-10
Location: Greater Denver Area, Colorado
Member #: 52517
Posts: 893
iTrader: (3)
Check out my gallery  Check out my vbgarage 

I bought mine in February and have had zero issues with the car. Now at 3300 miles -yeah, i live close to work
My only "problem" so far has been running out of money for mods, lol Not because the car is slow but because it's so much fun! I LOVE this car and will keep it for at least 6 years. Not a money issue either, it's paid in full. Right now there is not much i would trade it for
__________________________________________________
Black 2010 SS/TC GMS1, Hahn catted down pipe, Hahn catback exhaust | AEM intake | GM racing pedals | OZ Ultraleggera rims |DEPO 4th gen projectors w/ 6K HIDs; smoked LED tails | 20% tint |Pioneer z110bt head unit, Alpine PDX-5 amp, Focal speakers all around
Click the image to open in full size.
http://www.cardomain.com/ride/3835837
colodude18 is online now   Reply With Quote
Old 07-13-2010, 10:53 PM   #20
Senior Member

Points: 3,421, Level: 36
Points: 3,421, Level: 36 Points: 3,421, Level: 36 Points: 3,421, Level: 36
Level up: 48%, 79 Points needed
Level up: 48% Level up: 48% Level up: 48%
Activity: 0.7%
Activity: 0.7% Activity: 0.7% Activity: 0.7%

 
Join Date: 03-24-10
Location: wisconsin
Member #: 53760
Posts: 979
iTrader: (1)
Check out my gallery  Check out my vbgarage 

4500 nothing major, sunroof crap and a/c isnt cold ethier, besides usually noise crap no brake issues yet and yeah its not fast enough!!
strazdice is offline   Reply With Quote
Old 07-13-2010, 11:09 PM   #21
Senior Member

Points: 5,427, Level: 47
Points: 5,427, Level: 47 Points: 5,427, Level: 47 Points: 5,427, Level: 47
Level up: 39%, 123 Points needed
Level up: 39% Level up: 39% Level up: 39%
Activity: 0.9%
Activity: 0.9% Activity: 0.9% Activity: 0.9%

 
Join Date: 02-27-09
Location: Scranton, PA
Member #: 39643
Posts: 643
Images: 7
iTrader: (0)
Check out my gallery  Check out my vbgarage 

Well lets see. I bought my car on Halloween '09 and since then I've had to bring it in to the dealer for a bunch of stupid ****. Nothing mechanical or anything.
1. The rear window on the driver's side was not sealed from the factory and was leaking pretty bad. Got that fixed within the day.
2. Had to bring the car in for the recall about the brake lines possibly rubbing on the underbody of certain 2010 SS's between VIN *** and VIN ***. Unfortunately, mine was in between those VIN's. Took it in and got it fixed.
3. Brought it in to get the two front windows replaced along with the whiskers cuz the windows were scratched all to hell. This was in the middle of winter too and I've only put the windows down a couple times since I bought the car. After a little bit of complaining to the service manager, they replaced them under warranty for me.
4. Now I have to bring the car down next Wednesday to get the trunk repainted due to a factory blemish in the paint. There's a dark spot in front of the left base for the spoiler. It's about the size of a silver dollar and is obviously underneath the paint. The guy said it looks like a dark spot of primer when they painted it at the factory. They're also fixing the inside strip at the top of the passenger door panel cuz its peeling off toward the window.

Other than that, the car's great lol.
__________________


2010 SS Crystal Red Metallic Tintcoat, Fully Loaded. Tinted tail lights. High-rise wing. Debadged trunk. MPx Shorty Antenna. GMS1 equipped. K&N SRI. Bad-mab catless DP. 10% tint, 5% sunroof and windshield strip. Gen 4 Projectors w/ DDM 4500k headlights and fogs. First Crystal Red SS on css.net!!
CrystalRedSS is offline   Reply With Quote
Old 07-13-2010, 11:17 PM   #22
Senior Member

Points: 5,003, Level: 45
Points: 5,003, Level: 45 Points: 5,003, Level: 45 Points: 5,003, Level: 45
Level up: 27%, 147 Points needed
Level up: 27% Level up: 27% Level up: 27%
Activity: 0.1%
Activity: 0.1% Activity: 0.1% Activity: 0.1%

 
Join Date: 07-27-09
Location: Concord, NH
Member #: 49217
Posts: 3,730
iTrader: (1)
Check out my gallery  Check out my vbgarage 

Quote:
Originally Posted by OrangeCobaltSS/SC View Post
Well lets see. I bought my car on Halloween '09 and since then I've had to bring it in to the dealer for a bunch of stupid ****. Nothing mechanical or anything.
1. The rear window on the driver's side was not sealed from the factory and was leaking pretty bad. Got that fixed within the day.
2. Had to bring the car in for the recall about the brake lines possibly rubbing on the underbody of certain 2010 SS's between VIN *** and VIN ***. Unfortunately, mine was in between those VIN's. Took it in and got it fixed.
3. Brought it in to get the two front windows replaced along with the whiskers cuz the windows were scratched all to hell. This was in the middle of winter too and I've only put the windows down a couple times since I bought the car. After a little bit of complaining to the service manager, they replaced them under warranty for me.
4. Now I have to bring the car down next Wednesday to get the trunk repainted due to a factory blemish in the paint. There's a dark spot in front of the left base for the spoiler. It's about the size of a silver dollar and is obviously underneath the paint. The guy said it looks like a dark spot of primer when they painted it at the factory. They're also fixing the inside strip at the top of the passenger door panel cuz its peeling off toward the window.

Other than that, the car's great lol.
Ouch thats a decent amount wrong with it since you bought it.

But atleast they're fixing it all under warranty so thats a good thing
__________________
Cobalt's Gone...

New Ride: 2013 Mustang GT Brembo Package
Supercharged Guy is offline   Reply With Quote
Old 07-13-2010, 11:30 PM   #23
Senior Member
Points: 7,470, Level: 57
Points: 7,470, Level: 57 Points: 7,470, Level: 57 Points: 7,470, Level: 57
Level up: 60%, 80 Points needed
Level up: 60% Level up: 60% Level up: 60%
Activity: 1.2%
Activity: 1.2% Activity: 1.2% Activity: 1.2%

 
Join Date: 09-29-05
Location: Austin, TX
Member #: 3549
Posts: 1,083
Images: 14
iTrader: (1)
Check out my gallery  Check out my vbgarage 

Quote:
Originally Posted by Supercharged Guy View Post
I have 5,750 on mine and something is wrong with my fuel system or atleast thats what vince said.

My car kinda stutters/bogs at a low gear just puttin' around town, vince said he thinks it's a fuel pressure reg. or a fuel pump
I put some thought into this and came up with the following:

Since GM started putting the fuel pressure regulator into the fuel pump module, I've found that typically a bad fuel pressure regulator will cause an extended crank. When a regulator goes bad, the fuel pressure will drop very quickly to 0 when the vehicle is shut off. However I haven't noticed any lean conditions caused by this failure. This is reinforced by the fact that in a returnless direct injection system, the high pressure fuel pump provides the actual pressure needed and is electronically controlled.

Its possible that pump output could be low but that'd be more likely to show up under hard acceleration. The volume of fuel needed to drive the car at low speeds isn't great. So a bad fuel pump would be more likely to show up as a lean condition high in the RPM range.

I'm not going to claim that your mods are causing the problem or that its a tuning issue because I can't physically look at the car. I also don't claim to know everything and it could possibly be a bad pressure regulator or pump, I've seen stranger things happen.

Just thought I'd give my input based on the experience I've accrued over the years.
Malaclypse is offline   Reply With Quote
Old 07-14-2010, 07:55 AM   #24
Platinum Member

Points: 19,704, Level: 88
Points: 19,704, Level: 88 Points: 19,704, Level: 88 Points: 19,704, Level: 88
Level up: 71%, 146 Points needed
Level up: 71% Level up: 71% Level up: 71%
Activity: 6.1%
Activity: 6.1% Activity: 6.1% Activity: 6.1%

 
mongorat427's Avatar
 
Join Date: 07-23-09
Location: pittsburgh
Member #: 49113
Posts: 5,720
Images: 20
iTrader: (68)
Send a message via AIM to mongorat427
Mongorat427  XBL
Check out my gallery  Check out my vbgarage 

Quote:
Originally Posted by xodus View Post
only problem i had was 5th gear also... i took it in to have it adjusted since i do have warranty instead of doing it myself came back 3 hours later same thing , so i did it myself, and everything has been great ever since.
5th gear syncro and shift lever broke in mine. It was down for a month waiting on parts.
__________________
Go Fast Go Hard Trifecta Dealer Pittsburgh 09 SS TC Powell 4.45 Stage 2 Trans,E85,AEM Intake,Jennetty 3 in exhaust HAHN DP, DeJon Piping,Crazy Steve Intercooler,OTTP Stage 2 Mounts Ingalls Stiffy,TWM Shifter,Tallafero bushings. E60 tune by James Tune,Dual Interceptors,Ark Shorty, Depo Projectors ,Drag DR 31s ,5 x 114 conversion,R1 Rotors,Hawk Pads,Nitto NTO1s 255 40 17s,Devils Own Meth, D2 Coil overs, OTTP Hard Core Bar Powell Tow Hooks
mongorat427 is offline   Reply With Quote
Old 07-14-2010, 08:40 AM   #25
Senior Member

Points: 5,619, Level: 48
Points: 5,619, Level: 48 Points: 5,619, Level: 48 Points: 5,619, Level: 48
Level up: 35%, 131 Points needed
Level up: 35% Level up: 35% Level up: 35%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 05-03-08
Location: Halifax Nova Scotia, Canada
Member #: 25602
Posts: 1,322
Images: 17
iTrader: (0)
Check out my gallery  Check out my vbgarage 

forgot to mention i have to take it to teh dealer soon because the top of the drivers door hits the body and has started rubbing through the paint. want to take care of that b4 it is completely through / it starts to rust.
__________________
Whitty is offline   Reply With Quote
Old 07-14-2010, 08:40 AM
CobaltSS
Chevy Cobalt




Paid Advertisement
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:11 PM.


vBulletin copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.5.2
Admincp backup