P0089 (fuel pressure regulator 1 performance)HELP! - Cobalt SS Network
Cobalt SS Network Forums
Vendor Forums



Go Back   Cobalt SS Network > Engine Technical Discussion > 2.0L LNF Performance Tech


2.0L LNF Performance Tech 260hp and 260 lb-ft of torque Turbocharged tuner version.
Technical Discussions ONLY!

P0089 (fuel pressure regulator 1 performance)HELP!

This is a discussion on P0089 (fuel pressure regulator 1 performance)HELP! within the 2.0L LNF Performance Tech forums, part of the Engine Technical Discussion category; ok i got this code and my car is iddling like ****... it turns off and everything... what could this ...

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 05-26-2010, 01:11 AM   #1
Senior Member
iTrader: (3)
 
Join Date: 10-15-08
Location: florida
Member #: 30733
Posts: 2,637
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 18
Check out my gallery
Exclamation P0089 (fuel pressure regulator 1 performance)HELP!

ok i got this code and my car is iddling like ****... it turns off and everything... what could this possibly be
please help me!!!

thanks!
__________________
www.forumfaceoff.com

Rep your forum!
cardelino18 is offline   Reply With Quote
Old 05-26-2010, 01:27 AM   #2
Member
 
Join Date: 03-19-10
Location: Azusa, CA
Member #: 53667
Posts: 383
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 9
Check out my gallery
i got this code a few times at the track but never caused me a problem i think i took my air filter off one of the times maybe u have an intake leak


Quote:
Originally Posted by cardelino18 View Post
ok i got this code and my car is iddling like ****... it turns off and everything... what could this possibly be
please help me!!!

thanks!
__________________
Full Bolt-ons and my own custom E47/E85 Tune
brycerice13 is offline   Reply With Quote
Old 05-26-2010, 02:14 AM   #3
Senior Member
 
Join Date: 02-09-09
Location: Tejas
Member #: 38363
Posts: 4,377
Thanks: 0
Thanked 1 Time in 1 Post
Images: 147
Check out my gallery
This code is caused by your actual fuel pressure being above or below your commanded fuel pressure for a certain amount of time.

Basically your car didn't get the fuel pressure it was expecting, when it expected it. Off hand, I'd imagine this could be due to the fuel pump going out or a clogged fuel filter.

I had this pop up on a long 5 hour trip, where I did a few WOT runs every once in a while to mix things up. After a while the code went away on its own in my case. If your car is not idling properly, I'd take it in for warranty work on possibly the fuel pump going out.
__________________
2009 Cobalt SS/TC | G85 | RPD+Dashdaq
Engine build, mods, tires, and alignment I'm currently running are listed in VBGarage.

John 10:10 "The thief comes only to steal and kill and destroy; I have come that they may have life, and have it to the full."
Stamina is offline   Reply With Quote
Old 05-26-2010, 07:03 AM   #4
New Member
 
Join Date: 06-17-09
Location: PA
Member #: 47710
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
Check out my gallery
I got this code right after getting tuned didn't affect anything that I noticed, I cleared it and it never came back
__________________
2009 Cobalt SS T/C Black Sedan-LSD, Sunroof, GM Stage 1/Trifecta Selectable Tune...SOLD
09blacksedan is offline   Reply With Quote
Old 05-26-2010, 10:53 AM   #5
Premium Member
 
Cavalierssr's Avatar
 
Join Date: 07-11-08
Location: New Mexico
Member #: 27834
Posts: 672
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 25
cavalierss Check out my gallery
I got this code once too, Trifecta tune engaged did a few 2-3 pulls and it popped up. Cleared it and stayed off.
__________________

*NM Trifecta Dealer* 91Oct.-316hp/389tq E85-350hp/439tq
Cavalierssr is offline   Reply With Quote
Old 05-26-2010, 10:55 AM   #6
Senior Member
iTrader: (3)
 
Join Date: 10-15-08
Location: florida
Member #: 30733
Posts: 2,637
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 18
Check out my gallery
Quote:
Originally Posted by Stamina View Post
This code is caused by your actual fuel pressure being above or below your commanded fuel pressure for a certain amount of time.

Basically your car didn't get the fuel pressure it was expecting, when it expected it. Off hand, I'd imagine this could be due to the fuel pump going out or a clogged fuel filter.

I had this pop up on a long 5 hour trip, where I did a few WOT runs every once in a while to mix things up. After a while the code went away on its own in my case. If your car is not idling properly, I'd take it in for warranty work on possibly the fuel pump going out.
i cant get it into warranty... they wont fix it my dealer is too gay about that...
where would the fuel filter could be at?
__________________
www.forumfaceoff.com

Rep your forum!
cardelino18 is offline   Reply With Quote
Old 05-26-2010, 11:15 AM   #7
Senior Member
 
Join Date: 03-05-09
Location: Des Moines, IA
Member #: 40080
Posts: 1,028
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via AIM to Gimpster Send a message via MSN to Gimpster Send a message via Yahoo to Gimpster
Check out my gallery
There is a how-to on the fuel filter if you search, its in the same location as every other Cobalt.
__________________
2008 Black Cobalt SS Coupe

Current Mods: HPTuned to GMS1 • Gutted Stock DP • PRS TCAB's • OTTP Stage 1 Mounts • OTTP Shifter Bushings & Clamp
Gimpster is offline   Reply With Quote
Old 05-26-2010, 12:02 PM   #8
Senior Member
iTrader: (10)
 
Iam Broke's Avatar
 
Join Date: 10-24-08
Location: Dark side of the Moon
Member #: 31219
Posts: 3,356
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 4
Check out my gallery
Quote:
Originally Posted by Gimpster View Post
There is a how-to on the fuel filter if you search, its in the same location as every other Cobalt.
Damn, I didn't think the LNF's had one other than the sock in the tank.
__________________
'12 Camaro T3 Edition LS3 M6 - SLP TVS2300 & stuff on corn squeezins'
Iam Broke is offline   Reply With Quote
Old 05-26-2010, 08:45 PM   #9
Senior Member
 
Join Date: 02-09-09
Location: Tejas
Member #: 38363
Posts: 4,377
Thanks: 0
Thanked 1 Time in 1 Post
Images: 147
Check out my gallery
Quote:
Originally Posted by Iam Broke View Post
Damn, I didn't think the LNF's had one other than the sock in the tank.
That's the one I'm referring to.

If you've got a clog/restriction upstream, then the high pressure fuel pump may not be able to flow enough fuel.

I don't think it's got a second one, but if it does somehow, then that could be another place to check.
__________________
2009 Cobalt SS/TC | G85 | RPD+Dashdaq
Engine build, mods, tires, and alignment I'm currently running are listed in VBGarage.

John 10:10 "The thief comes only to steal and kill and destroy; I have come that they may have life, and have it to the full."
Stamina is offline   Reply With Quote
Old 05-27-2010, 12:21 AM   #10
Senior Member
iTrader: (3)
 
Join Date: 10-15-08
Location: florida
Member #: 30733
Posts: 2,637
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 18
Check out my gallery
there are 2 fuel pumps... the one in the tank and the one in the motor which is the high pressure pump...
__________________
www.forumfaceoff.com

Rep your forum!
cardelino18 is offline   Reply With Quote
Old 05-27-2010, 01:15 AM   #11
Senior Member
 
Join Date: 02-09-09
Location: Tejas
Member #: 38363
Posts: 4,377
Thanks: 0
Thanked 1 Time in 1 Post
Images: 147
Check out my gallery
Quote:
Originally Posted by cardelino18 View Post
there are 2 fuel pumps... the one in the tank and the one in the motor which is the high pressure pump...
Yes.

The code should be for the high pressure one. The low pressure one feeds the high pressure one and has the fuel filter. I'm saying that if the fuel filter in the low pressure one has a bunch of junk in it or something, then it may not be able to flow enough fuel to the high pressure fuel pump.
__________________
2009 Cobalt SS/TC | G85 | RPD+Dashdaq
Engine build, mods, tires, and alignment I'm currently running are listed in VBGarage.

John 10:10 "The thief comes only to steal and kill and destroy; I have come that they may have life, and have it to the full."
Stamina is offline   Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with LNF with Vac and random KR Sl0wbaltSS 2.0L LNF Performance Tech 15 02-05-2016 11:11 PM
Two codes on 09 SS no_ss Problems/Service/Maintenance 11 10-18-2015 11:58 PM
For Sale LDK intake manifold - black, lightly ported. Jesse Parts 15 10-13-2015 09:32 PM
CEL for Air/Fuel ratio DocSvensk 2.0L LNF Performance Tech 7 09-27-2015 02:24 PM
07 lsj-t problems gen 3 build Adiaz1ss Problems/Service/Maintenance 4 09-26-2015 11:51 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:20 PM.