Forum Jump Gallery Social Groups vBLive Garage Register Now Videos Link To Us Store Site Map TSBs
Cobalt SS Network Forums
The Cobalt SS Network is the leading resource for all Chevy Cobalts and related Delta
platform cars. Registered users do not see the above ads. Please Register - It's Free!
Vendor Forums



Go Back   Cobalt SS Network > Engine Technical Discussion > 2.4L LE5 Performance Tech
Sign in using an external account
Register Forgot Password?

Home Regional All Albums   FAQ Members List
2.4L LE5 Performance Tech 16 valve 171 hp EcoTec with 163 lb-ft of torque
Technical Discussions ONLY!

Codes P0010 & P0011 - VVT

This is a discussion on Codes P0010 & P0011 - VVT within the 2.4L LE5 Performance Tech forums, part of the Engine Technical Discussion category; Looks like the Intake cam Phaser may be bad. the oil was changed about 3500 miles ago (Always Mobile 1). ...

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 06-08-2012, 08:53 PM   #1
Senior Member

Points: 12,095, Level: 72
Points: 12,095, Level: 72 Points: 12,095, Level: 72 Points: 12,095, Level: 72
Level up: 12%, 355 Points needed
Level up: 12% Level up: 12% Level up: 12%
Activity: 12.7%
Activity: 12.7% Activity: 12.7% Activity: 12.7%

 
Join Date: 11-09-07
Location: Taunton MA
Member #: 21272
Posts: 7,256
Images: 3
iTrader: (14)
Check out my gallery 

Codes P0010 & P0011 - VVT

Looks like the Intake cam Phaser may be bad. the oil was changed about 3500 miles ago (Always Mobile 1). im getting these tow codes.

P0010 - Intake Cam Position sensor Open Circuit
P0011- Camshaft Position system actuator bank1 timing over-advance.

i have been doing some research. there are a few issues that could cause this.

Oil Condition
Oil Level / Pressure
Batt. Voltage.
Bad Actuator

I believe my issue may be related it he Batt. Voltage. car has been cranking slow and died the other day on me. i am going to get a new Batt this weekend. Hopefully this will fix it. im not 100% sure on this due to the face that both code are from the same side. it seems that when the solenoid goes, it causes both code (Makes Sense). i need a battery so i will start there, if not then i will do the solenoid.

I wanted to post all of this for other 2.4 / VVT owners who may have the same issue now or someday,

IF you do end up needing the part, i found one on eBay (Genuine GM Part) for $45
P/N - 12628347

apparently its a common issue on the Solstice Forum. this is where i found most of this info.

anyone else have or had this issue? im just nervous that my Timing Chain may be stretching.
__________________
06 SS/NA - 14.9@93.3: K&N|Powell|Koni|GMPP|ZZP|TWM|R1Concepts|Hawk|ARK|H IDWerks|Hurst

Last edited by LS6Rally; 06-08-2012 at 09:00 PM.
LS6Rally is offline   Reply With Quote
Old 06-08-2012, 09:06 PM   #2
Senior Member
Points: 11,732, Level: 71
Points: 11,732, Level: 71 Points: 11,732, Level: 71 Points: 11,732, Level: 71
Level up: 21%, 318 Points needed
Level up: 21% Level up: 21% Level up: 21%
Activity: 1.8%
Activity: 1.8% Activity: 1.8% Activity: 1.8%

 
Join Date: 05-07-08
Location: Minnesota
Member #: 25729
Posts: 6,388
iTrader: (1)
Check out my gallery 

You dont hear about many chains stretching...just saying
__________________
09 G5 - 2.4 Swapped Auto Supercharged E85 - 2.2 build on hold
nhanson is offline   Reply With Quote
Old 06-08-2012, 09:27 PM   #3
Senior Member

Points: 6,570, Level: 53
Points: 6,570, Level: 53 Points: 6,570, Level: 53 Points: 6,570, Level: 53
Level up: 10%, 180 Points needed
Level up: 10% Level up: 10% Level up: 10%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 09-03-10
Location: motor city
Member #: 56655
Posts: 2,745
iTrader: (17)
Check out my gallery 

I had the exact same codes, after $100 bucks at the dealer and both camshaft actuator solenoids I was fine. I wouldn't worry about the timing chain. Have you ever replaced your actuator solenoids?

edit: Also try deleting the codes then see how long they take to come back. If the codes come back immediately, like within 10 seconds of starting, it is probably voltage related. If it takes a little while to come back then it's 100% your cam actuator solenoids
__________________
89 Kawasaki Ninja EX500
06 Chevy Cobalt 2.4 Turbo
07 BMW 335i
noorj is online now   Reply With Quote
Old 06-08-2012, 10:15 PM   #4
Senior Member

Points: 12,095, Level: 72
Points: 12,095, Level: 72 Points: 12,095, Level: 72 Points: 12,095, Level: 72
Level up: 12%, 355 Points needed
Level up: 12% Level up: 12% Level up: 12%
Activity: 12.7%
Activity: 12.7% Activity: 12.7% Activity: 12.7%

 
Join Date: 11-09-07
Location: Taunton MA
Member #: 21272
Posts: 7,256
Images: 3
iTrader: (14)
Check out my gallery 

^ its somewhat intermittent, so im going to guess solenoids. ill do the batt anyways first cause im going to need one, and then do the actuator solenoid if needed.
__________________
06 SS/NA - 14.9@93.3: K&N|Powell|Koni|GMPP|ZZP|TWM|R1Concepts|Hawk|ARK|H IDWerks|Hurst
LS6Rally is offline   Reply With Quote
Old 06-08-2012, 11:32 PM   #5
Senior Member

Points: 3,446, Level: 36
Points: 3,446, Level: 36 Points: 3,446, Level: 36 Points: 3,446, Level: 36
Level up: 64%, 54 Points needed
Level up: 64% Level up: 64% Level up: 64%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 07-24-11
Location: WI
Member #: 61059
Posts: 1,038
Images: 119
iTrader: (6)
Check out my gallery 

Had the same thing happen. Intermittent issue after I would delete the code. Bought the solenoid for $65 at the dealer and installed it in the parking lot in less than 5 minutes. No issues since and that was almost two years ago.
__________________
Solstice GXP 5spd
13.08@110mph
hhrfreek is offline   Reply With Quote
Old 06-09-2012, 10:04 AM   #6
Platinum Member

Points: 6,500, Level: 52
Points: 6,500, Level: 52 Points: 6,500, Level: 52 Points: 6,500, Level: 52
Level up: 75%, 50 Points needed
Level up: 75% Level up: 75% Level up: 75%
Activity: 7.1%
Activity: 7.1% Activity: 7.1% Activity: 7.1%

 
Join Date: 02-24-08
Location: NY
Member #: 23567
Posts: 1,815
Images: 15
iTrader: (3)
Send a message via AIM to Gunney_07
Gunney007
Check out my gallery 

any one have a part number on the intake cam actuator solenoid
__________________
(k04)2.3/60',13.3/ET,113/MPH (s256) 2.2/60',12.5/ET,122/MPH


Gunney_07 is offline   Reply With Quote
Old 06-09-2012, 10:23 AM   #7
Senior Member

Points: 6,570, Level: 53
Points: 6,570, Level: 53 Points: 6,570, Level: 53 Points: 6,570, Level: 53
Level up: 10%, 180 Points needed
Level up: 10% Level up: 10% Level up: 10%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 09-03-10
Location: motor city
Member #: 56655
Posts: 2,745
iTrader: (17)
Check out my gallery 

I found the bag from when I bought mine so idk if it's intake or exhaust but this should help:

12628347

They state which one on the top near the wiring clip (INT or EXT)
__________________
89 Kawasaki Ninja EX500
06 Chevy Cobalt 2.4 Turbo
07 BMW 335i
noorj is online now   Reply With Quote
Old 06-09-2012, 11:03 AM   #8
Senior Member
Points: 1,166, Level: 18
Points: 1,166, Level: 18 Points: 1,166, Level: 18 Points: 1,166, Level: 18
Level up: 66%, 34 Points needed
Level up: 66% Level up: 66% Level up: 66%
Activity: 9.0%
Activity: 9.0% Activity: 9.0% Activity: 9.0%

 
Join Date: 12-19-11
Location: Pharr
Member #: 62865
Posts: 7,872
iTrader: (7)
Check out my gallery 

I had one of these codes cant remember which one exactly for like almost a year. It would randomly turn on sometimes and make my car shift hard as hell when it was on. Because it would turn the traction control on when the check engine light would come on. I switched out my intake actuator solenoid and it fixed the randomly turning on but I noticed that the traction control and sometimes the check engine light would still come on and make my car shift hard when I would step on it from a dig. Turns out I had a bad map sensor and I switched out the map sensor when I put my sc kit on. Hasnt done it ever since.

Not sure if you get the whole traction control thing also with your code but just in case you do thats what fixed mine lol. I did months of reading on those damn codes and heard alot of different stories similar to mine and there were apparently many different solutions to it. Usually its the solenoids and those are the cheapest and easy to install so id say start there.
__________________
*If Only i Was Fresh Crew*
*Gym Partner Cant Get His Car Running Crew*
*Say Dat To Me In Real Life Crew*
*Whippin And Flippin The Yam Crew*
*Missed My Exit Cuz I Was Thinking of Crews Crew*
*Gym Partner Sent Me A Snapchat of His Nipple Crew*
*No Homo Crew* *Rgv Ecotecs Crew* *Bobby Troll Specialist Crew*
Twoozofjuice is offline   Reply With Quote
Old 06-09-2012, 11:05 AM   #9
Senior Member
Points: 6,656, Level: 53
Points: 6,656, Level: 53 Points: 6,656, Level: 53 Points: 6,656, Level: 53
Level up: 53%, 94 Points needed
Level up: 53% Level up: 53% Level up: 53%
Activity: 1.1%
Activity: 1.1% Activity: 1.1% Activity: 1.1%

 
Join Date: 10-08-09
Location: Long Island, NY
Member #: 50779
Posts: 1,568
Images: 4
iTrader: (14)
Check out my gallery 

I had the actuators replaced over the winter car was throwing similar codes sucked good luck I feel like this is a very common issue with our 2.4's as I've seen a lot of these kind of threads pop up in the last 2 years or so
__________________
Tcobalt421 is offline   Reply With Quote
Old 06-09-2012, 11:24 AM   #10
Senior Member

Points: 6,570, Level: 53
Points: 6,570, Level: 53 Points: 6,570, Level: 53 Points: 6,570, Level: 53
Level up: 10%, 180 Points needed
Level up: 10% Level up: 10% Level up: 10%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 09-03-10
Location: motor city
Member #: 56655
Posts: 2,745
iTrader: (17)
Check out my gallery 

Quote:
Originally Posted by Tcobalt421 View Post
I had the actuators replaced over the winter car was throwing similar codes sucked good luck I feel like this is a very common issue with our 2.4's as I've seen a lot of these kind of threads pop up in the last 2 years or so
This, I think it's more a standard maintenance thing now
__________________
89 Kawasaki Ninja EX500
06 Chevy Cobalt 2.4 Turbo
07 BMW 335i
noorj is online now   Reply With Quote
Old 06-10-2012, 11:57 PM   #11
New Member
Points: 3,740, Level: 38
Points: 3,740, Level: 38 Points: 3,740, Level: 38 Points: 3,740, Level: 38
Level up: 60%, 60 Points needed
Level up: 60% Level up: 60% Level up: 60%
Activity: 0.3%
Activity: 0.3% Activity: 0.3% Activity: 0.3%

 
Join Date: 08-09-09
Location: Pennsylvania
Member #: 49546
Posts: 88
Images: 6
iTrader: (3)
Check out my gallery 

I just replaced mine the other day too. Mine was throwing a p0013 for the exhaust one. So, I replaced both since they redesigned them.

Intake- 12646783
Exhaust - 12646784

The old part #'s were 12628347 and 12628348. Also, the old ones are painted black and the new ones are nice and chrome looking. lol.

Last edited by x-ception; 06-11-2012 at 12:07 AM.
x-ception is offline   Reply With Quote
Old 06-11-2012, 04:38 PM   #12
Senior Member

Points: 12,095, Level: 72
Points: 12,095, Level: 72 Points: 12,095, Level: 72 Points: 12,095, Level: 72
Level up: 12%, 355 Points needed
Level up: 12% Level up: 12% Level up: 12%
Activity: 12.7%
Activity: 12.7% Activity: 12.7% Activity: 12.7%

 
Join Date: 11-09-07
Location: Taunton MA
Member #: 21272
Posts: 7,256
Images: 3
iTrader: (14)
Check out my gallery 

^ thanks,

i ordered both on Saturday should be at the dealer tomorrow.
__________________
06 SS/NA - 14.9@93.3: K&N|Powell|Koni|GMPP|ZZP|TWM|R1Concepts|Hawk|ARK|H IDWerks|Hurst
LS6Rally is offline   Reply With Quote
Old 06-21-2012, 01:06 PM   #13
Senior Member

Points: 12,095, Level: 72
Points: 12,095, Level: 72 Points: 12,095, Level: 72 Points: 12,095, Level: 72
Level up: 12%, 355 Points needed
Level up: 12% Level up: 12% Level up: 12%
Activity: 12.7%
Activity: 12.7% Activity: 12.7% Activity: 12.7%

 
Join Date: 11-09-07
Location: Taunton MA
Member #: 21272
Posts: 7,256
Images: 3
iTrader: (14)
Check out my gallery 

Put them in Today. exhaust wasn't throwing a code but i did both. hopefully i can get an Inspection Sticker now!
__________________
06 SS/NA - 14.9@93.3: K&N|Powell|Koni|GMPP|ZZP|TWM|R1Concepts|Hawk|ARK|H IDWerks|Hurst
LS6Rally is offline   Reply With Quote
Old 06-21-2012, 01:06 PM
CobaltSS
Chevy Cobalt




Paid Advertisement
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:17 PM.


vBulletin copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Admincp backup