Forum Jump Gallery Social Groups vBLive Garage Register Now Videos Link To Us Store Site Map TSBs
Cobalt SS Network Forums
The Cobalt SS Network is the leading resource for all Chevy Cobalts and related Delta
platform cars. Registered users do not see the above ads. Please Register - It's Free!
Vendor Forums



Go Back   Cobalt SS Network > General > Problems/Service/Maintenance
Sign in using an external account
Register Forgot Password?

Home Regional All Albums   FAQ Members List
Problems/Service/Maintenance Do you have problems with your new 2.0, 2.2, or 2.4L? What kind of service did you have done?

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 02-27-2008, 02:08 AM   #1
New Member

 
Join Date: 08-06-07
Location: Canada
Member #: 18971
Posts: 31
iTrader: (0)
Check out my gallery  Check out my vbgarage 

Question Engine light, traction control, power steering, gauges!

I have an 06 Cobalt LT I bought in August of 2007.

I brought it in for it's first scheduled maintenance on Feb 19th to get an oil change. The next day when I start it up, the traction control lights up and power steering shows up on the Info Console. I though, that's weird. I goes away when I'm driving home from work.

Next day, the Engine light, Traction control, power steering all show up and the transmission shifts at the wrong times, the engine stuttered when deaccelerating to the point where it sounds like it's going to shut down, the speedometer and tach needles are all over the place and the info console blinks on and off.

I brought it in to GM (still under warrenty) and had them look at it. They tell me the codes did come up, but after two days of diagnostics and road testing, they couldn't duplicate the same problems. I took my car back thinking everything was fine now. They kinda blamed the cold weather.

Now tonight Feb 27th, the traction control light comes up again. Sure enough, it's not working cause I made the tires spin and the engine didn't kick down at all.

Now what should I do here? Take it back again? Take it to another garage to look at it? Talk to the person who sold it to me?

Looking forward to hearing your input guys
__________________
2006 Cobalt LT 2.2
Victory Red
Stock stereo...for now


Chippathingy is offline   Reply With Quote
Old 02-27-2008, 02:11 AM   #2
Original Hayden Fanatic

Points: 104,050, Level: 100
Points: 104,050, Level: 100 Points: 104,050, Level: 100 Points: 104,050, Level: 100
Level up: 0%, 0 Points needed
Level up: 0% Level up: 0% Level up: 0%
Activity: 0.3%
Activity: 0.3% Activity: 0.3% Activity: 0.3%

Award-Showcase
 
REIGN SS's Avatar
 
Join Date: 05-06-06
Location: Dayton, O HI O
Member #: 7110
Posts: 33,179
Images: 93
iTrader: (0)
REIGN SS
Check out my gallery  Check out my vbgarage 

Check your fuses
__________________
REIGN SS is offline   Reply With Quote
Old 02-27-2008, 02:12 AM   #3
Senior Member
Points: 15,531, Level: 80
Points: 15,531, Level: 80 Points: 15,531, Level: 80 Points: 15,531, Level: 80
Level up: 37%, 319 Points needed
Level up: 37% Level up: 37% Level up: 37%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 03-30-05
Location: Warren, MI
Member #: 1173
Posts: 6,981
Images: 230
iTrader: (0)
Send a message via AIM to sneaky Send a message via Yahoo to sneaky
Check out my gallery  Check out my vbgarage 

sounds like a loose ground or a nasty short somewhere.
__________________
2009 Chevy Silverado EXT CAB Z-71 4x4 LT1 - Stock

2009 Wife -

Stage 3 marriage mod / thunder thighs / Badonkadonk butt / Big Ego / C Cup Mod / "Shaved" Decals / Nagging wife mod / German Sheppard Puppy Mod
sneaky is offline   Reply With Quote
Old 02-27-2008, 08:28 AM   #4
Senior Member

Points: 10,129, Level: 67
Points: 10,129, Level: 67 Points: 10,129, Level: 67 Points: 10,129, Level: 67
Level up: 20%, 321 Points needed
Level up: 20% Level up: 20% Level up: 20%
Activity: 0.5%
Activity: 0.5% Activity: 0.5% Activity: 0.5%

 
Join Date: 06-28-06
Location: Ontario,Canada
Member #: 8347
Posts: 2,213
Images: 2
iTrader: (0)
Check out my gallery  Check out my vbgarage 

I will go with the loose connection or fuse .Final answer
__________________
2006 Cobalt SS Super Charged
Coblasts is offline   Reply With Quote
Old 02-27-2008, 08:44 AM   #5
New Member

Points: 6,523, Level: 52
Points: 6,523, Level: 52 Points: 6,523, Level: 52 Points: 6,523, Level: 52
Level up: 87%, 27 Points needed
Level up: 87% Level up: 87% Level up: 87%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%

 
Join Date: 02-20-06
Location: ny
Member #: 5485
Posts: 87
iTrader: (0)
Send a message via AIM to jj13326
Check out my gallery  Check out my vbgarage 

mine was doing that what the dealer said the ABS was the problem, some how my abs was messing up my traction control and they replace the whole abs system well i hope you can get it taken care off. what ur gonna wanna do is take it in when the lights are on, when mine was doing that the only way i could get the dealer to see what it was, was by driving it there and leaveing the car on and have them bring out the **** to the car and then they found my problem but it wasnt untill 5 different visits with the lights off for them to find it "'06 cobalts have electical problems"
jj13326 is offline   Reply With Quote
Old 02-27-2008, 01:11 PM   #6
New Member

 
Join Date: 08-06-07
Location: Canada
Member #: 18971
Posts: 31
iTrader: (0)
Check out my gallery  Check out my vbgarage 

Okay, well I took it back to the dealer to see if they can find the problem. Of course they said to keep it running when I get there. I gave the service techs some of the possible reasons that you guys posted here and they appreiciated that. Hopefully that will lead them in the right direction.

Thanks again guys! I'll let you know how everything turns out. ...my poor Cobalt
__________________
2006 Cobalt LT 2.2
Victory Red
Stock stereo...for now


Chippathingy is offline   Reply With Quote
Old 03-05-2008, 09:34 AM   #7
New Member

 
Join Date: 08-06-07
Location: Canada
Member #: 18971
Posts: 31
iTrader: (0)
Check out my gallery  Check out my vbgarage 

Exclamation **update**

Got a call from GM and they tell me they are scratching their heads over the problems with my balt. They've test driven it for 4 days and the computer they hooked up to it shows that codes are popping up, but then they turn themselves back off. They don't know why the codes are appearing then disappearing.

Now they tell me they are going to be replacing the communication module and see if that works. I sure hope so!

So what is the communication module and what does it do?
__________________
2006 Cobalt LT 2.2
Victory Red
Stock stereo...for now


Chippathingy is offline   Reply With Quote
Old 03-05-2008, 10:52 AM   #8
Senior Member

Points: 6,675, Level: 53
Points: 6,675, Level: 53 Points: 6,675, Level: 53 Points: 6,675, Level: 53
Level up: 63%, 75 Points needed
Level up: 63% Level up: 63% Level up: 63%
Activity: 0%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: 05-05-05
Location: Missery, USA (showme state)
Member #: 1697
Posts: 920
iTrader: (0)
Check out my gallery  Check out my vbgarage 

They are probably goin to replace the EBTCM (electronic brake and traction control module)or EBCM (electronic brake control module). It depends on who your talking to as to what they call it . That one module controls both your antilock brakes and your traction control. I've read both trouble trees for the "ABS light on" and the "traction off" and both show to replace the module.
__________________
2007 Cobalt SS/SC Red His
Graphite leather w/ red inserts heated | LSD | sunroof | 6 disc
2008 G6 GT Convertible White Diamond Tricoat Hers
Light taupe leather w/ graphite inserts heated | 3.9L| FULLY loaded
fr33k is offline   Reply With Quote
Old 03-07-2008, 10:52 AM   #9
New Member

 
Join Date: 08-06-07
Location: Canada
Member #: 18971
Posts: 31
iTrader: (0)
Check out my gallery  Check out my vbgarage 

*UPDATE*

Well, I got my car back and so far it seems to be running just fine.

They replaced the BCM (Body Control Module), but only after another Balt came in with similar problems. The other Balt directed them to the faulty BCM, but even though that code never appeared on my Balt, they said that the problems between the two Balts were too similar. The service guy told me that if it wasn't for this other Balt that came in, they would still be scratching their heads over the problem(s). No matter what they checked, re-checked and tested, the codes kept coming back and shutting off on their own. They said they've never seen that before and even consulted with engineers over at GM to see what they might be able to figure out. Maybe my car is possesed?? Hahahaha!

But replacing the BCM made the codes go away. He took it out for a quick test drive and everthing seems to be fine.

I'm just happy to get my Balt back!

Any problems he said, and bring it straight back! I hope that's the last I even see of them... to be honest . Thanks again guys for your input!


__________________
2006 Cobalt LT 2.2
Victory Red
Stock stereo...for now


Chippathingy is offline   Reply With Quote
Old 07-28-2008, 06:58 PM   #10
New Member
 
Join Date: 07-28-08
Location: Cleveland
Member #: 28368
Posts: 1
iTrader: (0)
Check out my gallery  Check out my vbgarage 

Quote:
Originally Posted by Chippathingy View Post
*UPDATE*

Well, I got my car back and so far it seems to be running just fine.

They replaced the BCM (Body Control Module), but only after another Balt came in with similar problems. The other Balt directed them to the faulty BCM, but even though that code never appeared on my Balt, they said that the problems between the two Balts were too similar. The service guy told me that if it wasn't for this other Balt that came in, they would still be scratching their heads over the problem(s). No matter what they checked, re-checked and tested, the codes kept coming back and shutting off on their own. They said they've never seen that before and even consulted with engineers over at GM to see what they might be able to figure out. Maybe my car is possesed?? Hahahaha!

But replacing the BCM made the codes go away. He took it out for a quick test drive and everthing seems to be fine.

I'm just happy to get my Balt back!

Any problems he said, and bring it straight back! I hope that's the last I even see of them... to be honest . Thanks again guys for your input!


My Cobalt sounds like it is having the exact same problem as yours. My speedometer goes haywire, the power steering light comes on (and sometimes the power steering turns off for a little bit) and the most unsettling problem is when the car randomly shifts gears... It feels like i'm in a car with someone who doesn't know how to drive stick! I've taken it to the dealership 4 times now, but they have been unable to fix it. I've been online for hours looking for a possible fix. Did replacing the BCM work for you? The dealership tech suggested possibly having to replace the PCM. Any insight into this issue would be greatly appreciated!
hrd53 is offline   Reply With Quote
Old 07-28-2008, 06:58 PM
CobaltSS
Chevy Cobalt




Paid Advertisement
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 12:15 AM.


vBulletin copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.5.2
Admincp backup