Loose battery terminal - Cobalt SS Network
Cobalt SS Network Forums
Vendor Forums



Go Back   Cobalt SS Network > General > Problems/Service/Maintenance
Sign in using an external account
Register Forgot Password?


Home Regional All Albums   FAQ Members List
Problems/Service/Maintenance Do you have problems with your new 2.0, 2.2, or 2.4L? What kind of service did you have done?

Loose battery terminal

This is a discussion on Loose battery terminal within the Problems/Service/Maintenance forums, part of the General category; Battery went dead on my trunk battery 09 SS TC. Turned out the negative terminal was loose and disconnected! The ...

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
Old 01-18-2011, 01:54 AM   #1
Senior Member
 
Join Date: 09-30-09
Location: Los Angeles
Member #: 50610
Posts: 2,532
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 28
iTrader: (3)
Check out my gallery 

Loose battery terminal

Battery went dead on my trunk battery 09 SS TC. Turned out the negative terminal was loose and disconnected! The damn thing is a flimsy clamp that doesn't really fasten well. Anyone else experience this problem?
__________________
ronn is offline   Reply With Quote
Old 01-18-2011, 10:13 AM   #2
Member

 
Join Date: 05-30-10
Location: Newfoundland
Member #: 54971
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 1
iTrader: (0)
Check out my gallery 

nope. did you have the cables off recently?
__________________
zzp ic, injen ic piping, K&N sri, badmab catless dp, muffler delete and trifecta 22psi tune
rogersj is offline   Reply With Quote
Old 01-18-2011, 11:47 AM   #3
Moderator Alumni

 
Erod's Avatar
 
Join Date: 07-14-04
Location: Youngstown, Ohio
Member #: 90
Posts: 6,239
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 29
iTrader: (0)
Check out my gallery 

moved! not general!
__________________
99' Cavalier:06' Cobalt SS/SC:91' S-10:02' GTI VR6 24v:07' Chevy Silverado

Silverado for sale, click me!
Erod is offline   Reply With Quote
Old 01-18-2011, 04:21 PM   #4
Senior Member
 
Join Date: 09-30-09
Location: Los Angeles
Member #: 50610
Posts: 2,532
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 28
iTrader: (3)
Check out my gallery 

Quote:
Originally Posted by rogersj View Post
nope. did you have the cables off recently?
It can move when fully tightened. The clamp is pretty thin and only tightens so much. Think it's vibrations..the strap wasn't on, so that may have been it...but the battery is fastened pretty well without it on. I put electrical tape over the top to help keep it from vibrating loose.
__________________
ronn is offline   Reply With Quote
Old 01-18-2011, 06:14 PM   #5
Member

 
Join Date: 05-30-10
Location: Newfoundland
Member #: 54971
Posts: 323
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 1
iTrader: (0)
Check out my gallery 

your best bet is to cut it off and solder in a new one or crimp one on
__________________
zzp ic, injen ic piping, K&N sri, badmab catless dp, muffler delete and trifecta 22psi tune
rogersj is offline   Reply With Quote
Old 01-18-2011, 06:33 PM   #6
Senior Member
 
Join Date: 03-03-10
Location: nj
Member #: 53376
Posts: 512
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader: (1)
Check out my gallery 

go to the auto store and buy a new battery cable clamp, you can buy one that clamps the cable to the terminal, make sure you get the right terminal for the battery post they are diffrent sizes the neg terminal is smaller.
reddevil is offline   Reply With Quote
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:27 PM.

vBulletin copyright ©2000 - 2015, Jelsoft Enterprises Ltd.