oil light comes on after oil change. - Cobalt SS Network



Problems/Service/Maintenance Do you have problems with your new 2.0, 2.2, or 2.4L? What kind of service did you have done?

Reply
 
 
 
Thread Tools Search this Thread
Old 05-03-2007, 05:05 PM   #1
New Member
Thread Starter
 
Join Date: 02-01-07
Location: far away
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
oil light comes on after oil change.

my oil light has been coming on since ive gotten my car abck from an oil change, this is two weeks ago, i brought it in, they check filter and all, nothing is loose, but the light continues to come on, i have plenty of oil in it.. the thing is that my dad gets it when he drives and i never do. he tends to run in 2 or 3'd gear when it should be in the one above it. any ideas or the same problem, and when the light comes on, you can idle it for 15 minutes yes i did it, and it will stay on, but as soon as you tap your foot on the gas, it goes away.
louiefan is offline   Reply With Quote
Old 05-03-2007, 07:48 PM   #2
Senior Member
 
Join Date: 11-14-05
Location: Dumont, NJ
Posts: 997
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 58
Sounds like there isn't enough oil in it. If it's under warranty take it to the dealer let them chcek it out
bluecobaltss06 is offline   Reply With Quote
Old 05-03-2007, 08:02 PM   #3
New Member
Thread Starter
 
Join Date: 02-01-07
Location: far away
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
theres plenty of oil in it, i check it almost every 3 days just to see if its going down, but no dice.
louiefan is offline   Reply With Quote
Old 05-04-2007, 02:35 AM   #4
Senior Member
 
Join Date: 11-14-05
Location: Dumont, NJ
Posts: 997
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 58
When it comes to your oil light you shouldn't take anything lightly. Get it checked out. For all you know it could be somthing as serious as the oil pump failing, or maybe it's something as simple as the oil pressure sensor going bad. Get it checked out and put a post up, I'm kinda curious what's going on.
bluecobaltss06 is offline   Reply With Quote
Old 05-04-2007, 02:41 AM   #5
Senior Member
 
Join Date: 04-10-06
Location: CT
Posts: 837
Thanks: 0
Thanked 0 Times in 0 Posts
Get that checked out right away. You don't want to seize up the engine.
cobaltcoupe is offline   Reply With Quote
Old 05-04-2007, 05:55 PM   #6
Senior Member
 
Join Date: 06-28-06
Location: Ontario,Canada
Posts: 2,213
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 2
Had that problem with the same symptoms you describe with another car and it was the oil filter.
For the few dollars just try changing the oil filter and see if it goes away.
If not get it to the dealer right away could be a legit pressure problem.
Coblasts is offline   Reply With Quote
Old 05-05-2007, 11:32 AM   #7
New Member
Thread Starter
 
Join Date: 02-01-07
Location: far away
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
yeah, isnt the filter for the eco tec inside it, someone showed me at work how to but i completly forget, any words?
louiefan is offline   Reply With Quote
Old 05-05-2007, 11:35 AM   #8
Banned
 
D4u2s0t's Avatar
 
Join Date: 12-18-05
Location: North Jersey
Posts: 17,850
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 10
i'm assuming you reset the DIC?
D4u2s0t is offline   Reply With Quote
Old 05-05-2007, 11:50 AM   #9
New Member
 
Join Date: 11-05-06
Location: Central Mississippi
Posts: 159
Thanks: 0
Thanked 0 Times in 0 Posts
Does the light say low oil pressure or check engine oil level?
jojot is offline   Reply With Quote
Old 05-05-2007, 12:56 PM   #10
New Member
Thread Starter
 
Join Date: 02-01-07
Location: far away
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
no, it dosent give me any warnings except the light that comes on, and yes i reset it 2 minutes after i got the change done.
louiefan is offline   Reply With Quote
Old 05-17-2007, 01:30 AM   #11
New Member
 
Join Date: 06-20-06
Location: Tampa, FL
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
The oil filter is a drop in under the supercharger.
Hitman is offline   Reply With Quote
Old 05-17-2007, 02:35 AM   #12
Premium Member
 
WopOnTour's Avatar
 
Join Date: 07-04-05
Location: No where man
Posts: 730
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 5
The oil filter needs to be removed and inspected and the check valve "nipple" (on the bottom of the filter) checked for damage

Sometimes the nipple from the old filter might have broken off where the filter cap is tightened when a misalignment exists and then the new filter doesnt seat properly

Wop

Last edited by WopOnTour; 06-12-2007 at 05:31 PM.
WopOnTour is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Base model m62 build. DarrenGC 2.2L L61 Performance Tech 17 12-06-2015 03:34 PM
"supercharger Collant" leak brandon04 Problems/Service/Maintenance 46 10-21-2015 08:04 AM
HELP please 717ssbalt 2.0L LNF Performance Tech 9 10-02-2015 05:01 PM
Wrong Trans installed under warranty? importkiller Problems/Service/Maintenance 11 09-30-2015 08:18 PM
Powell Upgraded PCV system dennis69 2.0L LNF Performance Tech 5 09-28-2015 03:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:14 PM.