Forum Jump Gallery Social Groups vBLive Garage Register Now Videos Link To Us Store Site Map TSBs
Cobalt SS Network Forums
The Cobalt SS Network is the leading resource for all Chevy Cobalts and related Delta
platform cars. Registered users do not see the above ads. Please Register - It's Free!
Vendor Forums



Go Back   Cobalt SS Network > General > Problems/Service/Maintenance
Sign in using an external account
Register Forgot Password?

Home Regional All Albums   FAQ Members List
Problems/Service/Maintenance Do you have problems with your new 2.0, 2.2, or 2.4L? What kind of service did you have done?

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 09-04-2009, 08:09 PM   #1
New Member
 
Join Date: 08-07-09
Location: PA
Member #: 49480
Posts: 4
iTrader: (0)
Check out my gallery  Check out my vbgarage 

Turn signal in rear not working?

Hey guys, been reading here awhile, but never really had anything of value to post/ask until now.

I own a 2005 Cobalt SS and my rear turn signal is out. About a week ago whenever I had my left turn signal on, I noticed the "click" and blinking of the indicator were significantly faster than the right. Today, my back turn signal stopped functioning, yet the front left turn still works. If it just suddenly went out and I was not experiencing the quicker flashing, I would think it was the bulb alone. Should I be looking to buy a replacement bulb or is it something else? Any incite you guys would have would be greatly appreciated, as I have a feeling it may be a relay or switch.
FifthGear is offline   Reply With Quote
Old 09-04-2009, 09:03 PM   #2
New Member
 
Join Date: 09-19-06
Location: Newfoundland
Member #: 10486
Posts: 44
iTrader: (0)
Check out my gallery  Check out my vbgarage 

It's probably just the bulb...it's also a quick and cheap test. Pop a new one in (or switch one out from the other side for a test).
Chances are that it's the bulb based on what you describe though. If not, relay is next thing in list to check.
Haith is offline   Reply With Quote
Old 09-04-2009, 11:43 PM   #3
New Member
 
Join Date: 08-07-09
Location: PA
Member #: 49480
Posts: 4
iTrader: (0)
Check out my gallery  Check out my vbgarage 

Replaced the bulb, still no luck. Drove down to an AutoZone and they said they didn't carry the proper relay, as it was a dealer part. So I guess tomorrow I'll have to drive down to a GM dealer and have them straighten this out. Anyone know if the one-year warranty for Certified Used will cover this? (figure bumper to bumper probably doesn't cover wear & tear items most likely)

Also, if anyone has a cheaper/quicker alternative to where I could procure said relay, please let me know!
FifthGear is offline   Reply With Quote
Old 09-04-2009, 11:43 PM
CobaltSS
Chevy Cobalt




Paid Advertisement
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:23 PM.


vBulletin copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.5.2
Admincp backup