Turn Signal won't cancel. - Cobalt SS Network



Problems/Service/Maintenance Do you have problems with your new 2.0, 2.2, or 2.4L? What kind of service did you have done?

Reply
 
 
 
Thread Tools Search this Thread
Old 04-07-2007, 11:50 PM   #1
Senior Member
Thread Starter
 
Join Date: 12-18-05
Location: The Desert
Posts: 1,561
Thanks: 0
Thanked 0 Times in 0 Posts
Turn Signal won't cancel.

Anyone else had this happen to their Cobalt? It started this morning and it's really annoying. Gotta take it in to the dealership... again.

(My wife is so fed up it's probably going to be gone within the month.)

Last edited by hectanooga; 04-09-2007 at 02:08 AM. Reason: Cause I'm an OCD spelling and grammar Nazi.
hectanooga is offline   Reply With Quote
Old 04-07-2007, 11:56 PM   #2
Get low
 
biohazard's Avatar
 
Join Date: 03-29-06
Location: Crystal lake, IL
Posts: 3,476
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 247
like when u turn the wheel back? mines does it
biohazard is offline   Reply With Quote
Old 04-08-2007, 12:47 AM   #3
Senior Member
 
Join Date: 07-02-06
Location: Raleigh NC
Posts: 1,626
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 6
wow weird
rickyw is offline   Reply With Quote
Old 04-08-2007, 12:52 AM   #4
I'm old school
 
Halfcent's Avatar
 
Join Date: 02-16-05
Location: Nashville
Posts: 6,901
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 480
Failure to auto-cancel. Yes, mine does that every now and then.
Halfcent is offline   Reply With Quote
Old 04-08-2007, 12:45 PM   #5
Senior Member
Thread Starter
 
Join Date: 12-18-05
Location: The Desert
Posts: 1,561
Thanks: 0
Thanked 0 Times in 0 Posts
I think something physically broke in the steering column. Usually you can hear the tabs clicking when the signal is on and you are turning your wheel. Now, I don't hear that. I'll know for sure when it goes into the dealership this week. I was curious how widespread this problem was, if at all.
hectanooga is offline   Reply With Quote
Old 04-08-2007, 12:48 PM   #6
Senior Member
 
kissmySS's Avatar
 
Join Date: 05-27-05
Location: London, Ontario
Posts: 1,306
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 20
Ya there is a switch inside the column that is most likely broke.. Take Er in..!
kissmySS is offline   Reply With Quote
Old 04-09-2007, 12:07 AM   #7
I'm old school
 
Halfcent's Avatar
 
Join Date: 02-16-05
Location: Nashville
Posts: 6,901
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 480
The "sticks" that are mounted to the column are conplete units. That can literally be unplugged and removed from the column as separate unit. The cancelling mechanisms are within each one. The column itself just has the cam trigger.
Halfcent is offline   Reply With Quote
Old 04-09-2007, 12:12 AM   #8
Senior Member
 
MachiBLue's Avatar
 
Join Date: 02-20-05
Location: Chicago
Posts: 3,402
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 60
I've had that happening in mine for a couple of months now. I havent taken it to the dealer yet, so I don't know whats wrong with it.
MachiBLue is offline   Reply With Quote
Old 04-09-2007, 07:50 PM   #9
Senior Member
Thread Starter
 
Join Date: 12-18-05
Location: The Desert
Posts: 1,561
Thanks: 0
Thanked 0 Times in 0 Posts
Just got back from the dealership...

"SIR Coil canceling cam plate separated from coil, verify concern. Remove steering column covers and turn signal switch for access. Inspect and found cam plate separated from coil. Necessary to SOP coil. Reassemble vehicle."

Thats verbatim from the service invoice. Took it in today to get a new radio and fix my turn signal auto-cancel. I'm waiting on them to special order the part to fix that, so I get to go back again when it arrives. (And they need to fix my dash because they jacked it up when they put the radio in.)
hectanooga is offline   Reply With Quote
Old 06-21-2009, 02:43 PM   #10
New Member
 
Join Date: 01-05-06
Location: CT
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
I'm on my second Turn Signal switch/stalk for this - for a 2006 Cobalt LS - with 85K+ miles - I'm looking to replace the unit myself, wondering how hard to do this is? - (don't want to be messing around the airbag)- my dealer closed up last year and not looking to start a relationship with another.

From looking at the part I'm figuring it's just a few screws - and a wire - would I be able to use a Chilton/Haynes manual ?
pixarwolf is offline   Reply With Quote
Old 06-21-2009, 03:01 PM   #11
Senior Member
 
Join Date: 11-20-07
Location: Pittsburgh, Pistolvania
Posts: 2,961
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 23
Yeah, take it in. The part on the controls that catches on the gear set in the steering column is broken.
Nighthawk243 is offline   Reply With Quote
Old 06-21-2009, 03:23 PM   #12
New Member
 
Join Date: 01-05-06
Location: CT
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
so it would be in the switch module itself ? -

I'm very tight on money these days (who isn't) so no trips to a $tealership if I can replace a part myself-


only going to keep this car another year until I pay it off - (she's in very bad shape)
pixarwolf is offline   Reply With Quote
Old 06-22-2009, 06:45 PM   #13
I'm old school
 
Halfcent's Avatar
 
Join Date: 02-16-05
Location: Nashville
Posts: 6,901
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 480
Each column control lever is a replaceable unit. Just open up the colum (3 screws underneath) and you will be able to plainly see the units and how to take them out. It's very easy.
Halfcent is offline   Reply With Quote
Old 06-30-2009, 04:25 PM   #14
New Member
 
Join Date: 01-05-06
Location: CT
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
just replaced the switch unit - amazing all the plastic the car is made of - and then the turn signal says "MADE IN CHINA" ahh that explains everything -
pixarwolf is offline   Reply With Quote
Old 07-17-2009, 07:48 AM   #15
New Member
 
Join Date: 05-18-08
Location: louisville
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 1
I have been having problems with my turn signals not working correct. When I first got the car at 36,000 miles it wasn't that bad however it did get worse and now my turn signals won't cancel at all after 68,000. Now I also notice that when I turn my wipers on high they sometimes don't come on. Does anybody know how much it cost to replace the part for the turn signals? And does anybody know what could be wrong with my wipers?
chadnky is offline   Reply With Quote
Old 07-18-2009, 04:22 AM   #16
New Member
 
Join Date: 05-31-08
Location: WI
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
I had this problem too. It was kind of easy to fix. Take the swith out and take it apart. there is a straight strip of metal that the use as a spring that you need to bend a bit to make it a bit stronger and that fixed my problem.
bruizer69_210 is offline   Reply With Quote
Old 06-29-2011, 07:51 PM   #17
Senior Member
iTrader: (2)
 
CobaltVenomSS's Avatar
 
Join Date: 02-20-07
Location: Tyler,Texas
Posts: 11,676
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 90
Does anyone knw the part number for the turn signal lever??? Mine won't stay on when the left one is on and won't cancel when the right one is on .....
CobaltVenomSS is offline   Reply With Quote
Old 06-29-2011, 07:53 PM   #18
New Member
 
Join Date: 08-15-10
Location: Ft. Lauderdale
Posts: 169
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 2
You should just keep turning. Problem solved.
Refractor is offline   Reply With Quote
Old 06-29-2011, 08:25 PM   #19
Senior Member
 
Tomtwtwtw's Avatar
 
Join Date: 03-30-06
Location: Chandler, AZ
Posts: 5,492
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 14
Didn't even know this thread existed, but I'm glad it does. I have 40k miles on my '08 SS and my 2nd turning signal level is going out, and this time I'm out of warranty. Good to know it's a simple fix.
Tomtwtwtw is offline   Reply With Quote
Old 06-29-2011, 09:02 PM   #20
Senior Member
iTrader: (2)
 
CobaltVenomSS's Avatar
 
Join Date: 02-20-07
Location: Tyler,Texas
Posts: 11,676
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 90
I just need the part number so I can get it off gmpartsdirect lol
CobaltVenomSS is offline   Reply With Quote
Old 06-29-2011, 10:32 PM   #21
Senior Member
 
Join Date: 12-05-10
Location: newmarket
Posts: 3,895
Thanks: 0
Thanked 2 Times in 2 Posts
Could just get a new switch outta a scrap yard for cheap , happened to
Me a few times under warranty, replaced the switch both times
C_A_D88 is offline   Reply With Quote
Old 06-30-2011, 06:24 AM   #22
Senior Member
 
Join Date: 10-01-08
Location: Philthydelphia, PA
Posts: 4,793
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 6
if your still under warranty then take it in to the dealer. if not, its going to cost you 3x more to have them replace it when you can do it yourself in 20 minutes.
06SS ALL DAY is offline   Reply With Quote
Old 07-01-2011, 12:43 PM   #23
Senior Member
 
jlong3382's Avatar
 
Join Date: 02-09-08
Location: Indiana
Posts: 1,608
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 24
I changed my steering wheel and have had this problem intermittently ever since.
jlong3382 is offline   Reply With Quote
Old 07-01-2011, 02:04 PM   #24
Supporting Vendor
iTrader: (5)
 
CrateEngineDepot's Avatar
 
Join Date: 07-06-05
Location: Grayslake IL
Posts: 3,572
Thanks: 0
Thanked 28 Times in 10 Posts
Images: 21


LINK

In stock, Ive installed these, they are not hard to do.
CrateEngineDepot is offline   Reply With Quote
Old 07-01-2011, 02:06 PM   #25
Senior Member
 
Tomtwtwtw's Avatar
 
Join Date: 03-30-06
Location: Chandler, AZ
Posts: 5,492
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 14
Quote:
Originally Posted by CrateEngineDepot View Post


LINK

In stock, Ive installed these, they are not hard to do.
Sweet! I'm going to bookmark the product page as I'm sure I'll be visiting it soon enough.
Tomtwtwtw is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New steering rack Solaris99 08-10 SS Turbocharged General Discussion 27 08-31-2016 08:45 PM
Akron/Canton Cobalt Meet 06MetallicBalt Mid East 7 06-14-2016 03:17 PM
Wideband o2 Stimulating Factory NB o2 Tupp 2.2L LAP Performance Tech 5 01-02-2016 01:04 PM
Recommended tools for a beginner. tuned08ss The Lounge 34 10-02-2015 07:14 PM
everytime i fill up my balt has trouble turning on roth Problems/Service/Maintenance 2 09-26-2015 01:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:58 PM.