LDK CRATE MOTOR coolant wonít read on the dash - Cobalt SS Network

Go Back  Cobalt SS Network > General > 08-10 SS Turbocharged General Discussion
LDK CRATE MOTOR coolant wonít read on the dash >

LDK CRATE MOTOR coolant wonít read on the dash

08-10 SS Turbocharged General Discussion Discuss the 2008 - 2009 Chevy Cobalt SS Turbocharged. On sale since the second quarter of 2008.

LDK CRATE MOTOR coolant wonít read on the dash

Reply

 
 
 
Old 08-10-2018, 05:55 PM
  #1  
New Member
Thread Starter
 
Join Date: 07-30-18
Location: Va
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
LDK CRATE MOTOR coolant wonít read on the dash

brand new everything on the vehicle head to toe . I even just bought another coolant temp sensor and installed it but sill no change . It reads 61 F at first then once u ride it down the road it trips a cel and three dashes show on the display . Iíve read about thermostats but this thing is brand new . I suppose Iíll try that now but any other ideas would help p119 code
Boosted_doe is offline  
Reply With Quote
Old 08-10-2018, 07:42 PM
  #2  
Senior Member
 
Join Date: 03-09-14
Location: Virginia
Posts: 610
Thanked 18 Times in 16 Posts
Probably bad thermostat
zeeky420 is offline  
Reply With Quote
Old 08-10-2018, 08:00 PM
  #3  
New Member
Thread Starter
 
Join Date: 07-30-18
Location: Va
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by zeeky420 View Post
Probably bad thermostat
I also just noticed my 2 heater core hoses are flip flopped 🤦🏻*♂️ But idk if that would off the temp reading . Iíll try that first then the therm .
Boosted_doe is offline  
Reply With Quote
Old 08-11-2018, 12:04 AM
  #4  
Senior Member
iTrader: (1)
 
Join Date: 10-27-07
Location: Abbotsford BC, Canada
Posts: 5,269
Thanked 149 Times in 133 Posts
a quick google search shows p0119 being coolant temp sensor intermittent circuit. since you have tried another sensor and that didnt fix it, its more than likely a wiring problem. check the harness for any chafing or bare wires, check the pins to make sure they look ok and arent mangled (both the temp sensor and ecm).
Sharkey is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cw383
Parts
5
05-03-2016 09:20 PM
REIGN SS
General Cobalt
63
02-23-2011 06:14 PM
1fastss/sc
Problems/Service/Maintenance
7
03-08-2009 03:13 AM
krenfro88
2.4L LE5 Performance Tech
19
07-25-2008 07:16 AM
j27
JBodyPerformance
1
03-28-2008 07:01 PM


Thread Tools
Search this Thread