3 codes n was wondering what it could b - Cobalt SS Network



2.2L LAP Performance Tech 2.2L LAP Performance Tech (2009+) 155 hp EcoTec with 150 lb-ft of torque
Technical Discussions ONLY!

Reply
 
 
 
Thread Tools Search this Thread
Old 04-14-2017, 09:48 PM   #1
New Member
Thread Starter
 
bahoodle's Avatar
 
Join Date: 11-01-16
Location: Western NY
Posts: 43
Thanked 1 Time in 1 Post
3 codes n was wondering what it could b

p0171 - fuel sytem too lean (Bank 1)
P1171 Fuel Trim Cylinder balance
P0300 multiple engine misfires detected

car is a 2009 2.2 with 220,000 miles
bahoodle is offline   Reply With Quote
Old 04-15-2017, 05:39 PM   #2
New Member
Thread Starter
 
bahoodle's Avatar
 
Join Date: 11-01-16
Location: Western NY
Posts: 43
Thanked 1 Time in 1 Post
soo im pretty sure its from a dirty er clogged fuel injector but idk figure id get some input from u guys :P i mean if bank 1s running lean and it has a fuel trim cylinder balance code id assume that would cause the misfire since one cylinders not getting enough gas but enough spark so its not combusting right but yea u guys think that its a fuel injector issue? thanks for any help/ suggestions
bahoodle is offline   Reply With Quote
Old 04-15-2017, 08:19 PM   #3
Platinum Member
Platinum Member
iTrader: (6)
 
Join Date: 07-19-10
Location: Denver, Colorado
Posts: 17,042
Thanked 239 Times in 209 Posts
4 cylinders only have bank 1. It's in reference to cylinder banks so a v8 has 2 banks of 4 cylinders.

As far as the codes goes, start with checking your plugs, and compression before you go guessing a injector problem. That would have a misfire on a single cylinder not random. Without looking at data coming off a scanner it's had to say.
ECaulk is online now   Reply With Quote
Old 04-16-2017, 11:14 AM   #4
New Member
Thread Starter
 
bahoodle's Avatar
 
Join Date: 11-01-16
Location: Western NY
Posts: 43
Thanked 1 Time in 1 Post
ive got oil on the 2nd plug from the left on the coil boot side so im thinking i gotta replace the valve cover gasket :/ also the airbox has a heavy coat of oil in it :/ anyways im gonna do a compression test tomorrow n hopefully everythings ok

Last edited by bahoodle; 04-16-2017 at 11:29 AM.
bahoodle is offline   Reply With Quote
Old 04-16-2017, 08:38 PM   #5
Platinum Member
Platinum Member
iTrader: (6)
 
Join Date: 07-19-10
Location: Denver, Colorado
Posts: 17,042
Thanked 239 Times in 209 Posts
I'm sure something is tired with 220k, depending on the OCI and the UOAs it could be nearing the end of life for the engine
ECaulk is online now   Reply With Quote
Old 04-18-2017, 09:49 AM   #6
Senior Member
iTrader: (1)
 
Join Date: 02-03-16
Location: Kansas
Posts: 1,136
Thanked 35 Times in 34 Posts
Like ECaulk said you should read your spark plugs and look for variation. Not on my car but on a truck I own I have had lean conditions caused by a dirty restrictive fuel filter combined with a fuel pump on it's way out. The spark plugs may indicate if it is a problem in a single cylinder (like a dirty injector) or with all cylinders (possible low fuel pressure).
jdbaugh1 is online now   Reply With Quote
The Following User Says Thank You to jdbaugh1 For This Useful Post:
bahoodle (04-18-2017)
Old 04-18-2017, 10:20 PM   #7
New Member
Thread Starter
 
bahoodle's Avatar
 
Join Date: 11-01-16
Location: Western NY
Posts: 43
Thanked 1 Time in 1 Post
yea my codes went away after tightening intake bolts valve cover bolts messin wit o2 sensor cables anyways im gettin it inspected once my steering shaft gets here but after that im gonna check the compression n hopefully they're all close to 120..... lol
bahoodle is offline   Reply With Quote
Old 04-18-2017, 10:21 PM   #8
New Member
Thread Starter
 
bahoodle's Avatar
 
Join Date: 11-01-16
Location: Western NY
Posts: 43
Thanked 1 Time in 1 Post
n the plugs all looked the same aside from oil on one of em on the top side of the plug but the cylinders were all really clean looking which i thought was weird :/
bahoodle is offline   Reply With Quote
Old 04-19-2017, 11:00 AM   #9
Senior Member
iTrader: (1)
 
Join Date: 02-03-16
Location: Kansas
Posts: 1,136
Thanked 35 Times in 34 Posts
Quote:
Originally Posted by bahoodle View Post
yea my codes went away after tightening intake bolts valve cover bolts messin wit o2 sensor cables anyways im gettin it inspected once my steering shaft gets here but after that im gonna check the compression n hopefully they're all close to 120..... lol
You tightened the intake manifold bolts?vvYou think you had a vacuum leak that was causing lean condition?

Hopefully your compression is is much higher than 120 lol.
jdbaugh1 is online now   Reply With Quote
Old 04-19-2017, 11:20 AM   #10
Platinum Member
Platinum Member
iTrader: (6)
 
Join Date: 07-19-10
Location: Denver, Colorado
Posts: 17,042
Thanked 239 Times in 209 Posts
Quote:
Originally Posted by jdbaugh1 View Post
You tightened the intake manifold bolts?vvYou think you had a vacuum leak that was causing lean condition?

Hopefully your compression is is much higher than 120 lol.
I'm going to guess the vacuum leak caused that lean condition.

Def hope the compression is higher than 120, even on an engine with 220k.
ECaulk is online now   Reply With Quote
Old 04-19-2017, 07:01 PM   #11
New Member
Thread Starter
 
bahoodle's Avatar
 
Join Date: 11-01-16
Location: Western NY
Posts: 43
Thanked 1 Time in 1 Post
yea it was only running rough on a cold start so i checked that all the bolts were tight and they weren't lol it had a leak from the dp to resonator the bolt heads rusted completely off so i fixed it wit some ghetto flange things that force it back together but the codes are gone which is nice :P jus gotta put my intermediate shaft in n the car will be flawless for 200 miles til something else breaks lol
bahoodle is offline   Reply With Quote
Old 04-19-2017, 07:07 PM   #12
New Member
Thread Starter
 
bahoodle's Avatar
 
Join Date: 11-01-16
Location: Western NY
Posts: 43
Thanked 1 Time in 1 Post
and i could'nt remember what it was supposed to b 150 on a n/a and 180 a turbo i think idk ill post back to this once i do it im just waiting for a guy at work to bring me his gauge
bahoodle is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:46 PM.