Go Back  Cobalt SS Network > General > Problems/Service/Maintenance
07 Cobalt No Crank! ABS/TCM/Steering Control >

07 Cobalt No Crank! ABS/TCM/Steering Control

Problems/Service/Maintenance Do you have problems with your new 2.0, 2.2, or 2.4L? What kind of service did you have done?

07 Cobalt No Crank! ABS/TCM/Steering Control

Old 05-15-2019, 11:42 PM
  #1  
New Member
Thread Starter
 
Join Date: 05-13-19
Location: New Jersey
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Exclamation 07 Cobalt No Crank! ABS/TCM/Steering Control






A few weeks ago one morning the car wouldn’t start. No crank no nothing, silence when I turned the key to run. The dash didn’t display the CEL when in power only position, but did suddenly say “service air bag”. After a few seconds of sitting with the key turned to power only, the dash came back (and the CEL as it’s supposed to) and then when the key was turned to run it started up fine, no CEL, no service air bag notice. This has happened almost every day since, but only after the car has been sitting for a night or longer, so I scanned for codes and found the two codes above.

Today I really dove into the forums and found a few possible fixes which I tired. I grounded the TCM to the frame above the strut, checked all TCM and ECM connectors and pins for oil from the oil pressure sensor leak I had, checked related fuses in the main fuse box, checked both BCM connectors and pins, checked related fuses on the BCM, removed and cleaned the grounds on the front of the transmission, behind the fuse box, below the coolant reservoir tank (what a pain in the ass), below the driver side headlight (what an even bigger pain in the ass), above the driver side headlight, and cleaned out an unknown circular connector with a lot of pins and two rectangular slots on the front center of the transmission. I had a leaking oil pressure sensor which I replaced a few days ago, that circular connector was pretty oily before I cleaned it from the old leak. No other electrical connectors seem to have been reached by the oil leak.

Sadly, all that did not seem to fix it.. The car did start, but not until a few tries and again letting it sit with the key in the power position for a bit. Some days it won’t start at all! I’d really appreciate help, maybe the wiring diagrams of the modules from the codes if someone can find them? I know for fact it’s electrical, and not a bad TCM/BCM, probably a short or bad ground somewhere, but right now I’m swinging in the dark without a real idea of where the likely culprit is.

Heres to hoping I can save her, just replaced the whole front end, evap system, and god knows how many other things in the past year!
GuardLife is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jimmydean
2.2L L61 Performance Tech
16
06-09-2016 03:04 AM
Flummoxed
Drivetrain
3
01-12-2014 09:59 AM
yellow2003xtreme
Drivetrain
3
04-18-2013 01:46 AM
Nickc84
General Cobalt
18
02-16-2009 03:13 PM
sushidog
2.4L LE5 Performance Tech
5
04-10-2006 08:12 PM


Thread Tools
Search this Thread
Quick Reply: 07 Cobalt No Crank! ABS/TCM/Steering Control


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.