Doesnít Want To Decelerate - Cobalt SS Network

Go Back  Cobalt SS Network > General > Problems/Service/Maintenance
Doesnít Want To Decelerate >

Doesnít Want To Decelerate

Problems/Service/Maintenance Do you have problems with your new 2.0, 2.2, or 2.4L? What kind of service did you have done?

Doesnít Want To Decelerate

Reply

 
 
 
Old 07-11-2018, 04:39 AM
  #1  
New Member
Thread Starter
 
Join Date: 07-11-18
Location: Hubbard,OH
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Doesnít Want To Decelerate

So,

At one point I had a pretty common issue Iíve read about. Basically a surge from 5-1.5k at idle and when pressing in the clutch. My fix was indeed a vacuum leek. I was planning to dig into the throttle body and clean it but this fixed it so I put it aside. Now Iím noticing when I downshift, regardless what rpm Iím at, the car lurches and the exhaust note changes as if Iím holding the throttle open slightly. It jumpes around and stumbles debating on whether to decelerate or excelerate. What gear or rpm doesnít change that fact. Iím starting to get lurching while my foot is off the gas in first gear. Also, if Iím traveling speed and I pull into neutral it sits above 1-1.5rmp until I rest at a complete stop. My tuner hooked a scan tool to his laptop while on a drive around and showed on the data that the computer is holding my throttle at 20 to 25% occasionally when my foot is not on the gas pedal. Any thoughts?

Does she just want to go faster all the time!?

Last edited by BOMEXCOBALT; 07-11-2018 at 04:43 AM. Reason: Grammar errors
BOMEXCOBALT is offline  
Reply With Quote
Old 07-11-2018, 08:53 AM
  #2  
Senior Member
iTrader: (1)
 
Join Date: 02-03-16
Location: Kansas
Posts: 3,920
Thanked 124 Times in 120 Posts
What Cobalt do you have? Mods and tune? Any engine codes?
jdbaugh1 is offline  
Reply With Quote
Old 07-11-2018, 11:28 AM
  #3  
New Member
Thread Starter
 
Join Date: 07-11-18
Location: Hubbard,OH
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by jdbaugh1 View Post
What Cobalt do you have? Mods and tune? Any engine codes?
06 SS/SC. Cold air intake, 3Ē catless exhaust, long tube headers. Other then that, stock. It is throwing an engine code. Itís always on. From what I remember is something about air flow/fuel? I could read it again if that would help.
BOMEXCOBALT is offline  
Reply With Quote
Old 07-11-2018, 11:58 AM
  #4  
Senior Member
iTrader: (1)
 
Join Date: 02-03-16
Location: Kansas
Posts: 3,920
Thanked 124 Times in 120 Posts
It could help considerably
jdbaugh1 is offline  
Reply With Quote
Old 07-11-2018, 12:34 PM
  #5  
New Member
Thread Starter
 
Join Date: 07-11-18
Location: Hubbard,OH
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by jdbaugh1 View Post
It could help considerably
Iíll be at my tuners place at 12:30. Iíll have it posted then.
Thank you for your help brother!
BOMEXCOBALT is offline  
Reply With Quote
Old 07-11-2018, 12:37 PM
  #6  
Senior Member
iTrader: (1)
 
Join Date: 02-03-16
Location: Kansas
Posts: 3,920
Thanked 124 Times in 120 Posts
Haven't helped you yet lol but I do know that with the electronic throttle being ECU controlled, having a sensor read funny can make it do strange things.
jdbaugh1 is offline  
Reply With Quote
Old 07-11-2018, 03:00 PM
  #7  
New Member
Thread Starter
 
Join Date: 07-11-18
Location: Hubbard,OH
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by jdbaugh1 View Post
Haven't helped you yet lol but I do know that with the electronic throttle being ECU controlled, having a sensor read funny can make it do strange things.
I got stopped without tags. Ordered custom plates on my birthday and was trying to hold off so I didnít have to pay for registration 2 times for the same car in a week 😐 my luck.

Iíll the the results of the reading posted as soon as I get out of this hell hole. Wish me luck lol.
BOMEXCOBALT is offline  
Reply With Quote
Old 07-12-2018, 09:37 AM
  #8  
New Member
Thread Starter
 
Join Date: 07-11-18
Location: Hubbard,OH
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
My tuner wasnít available to run the codes for me, so I pulled the throttle body off and cleaned it up. No fix after ~70 miles. All the gunk from the rag was in the throttle body 😯 Was easy to take apart. 1 vac line and 1 sensor.




BOMEXCOBALT is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Chav97
2.0L LNF Performance Tech
8
01-02-2017 08:31 PM
vpec13
The Lounge
24
12-12-2011 09:31 PM
baddabang15
The Lounge
4
06-10-2011 12:01 PM
Erod
The Lounge
24
11-11-2007 11:27 PM
Dman
The Lounge
5
12-13-2005 02:35 AM


Thread Tools
Search this Thread
Quick Reply: Doesnít Want To Decelerate


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.