Turn Signal Problem? - Cobalt SS Network



Problems/Service/Maintenance Do you have problems with your new 2.0, 2.2, or 2.4L? What kind of service did you have done?

Reply
 
 
 
Thread Tools Search this Thread
Old 01-28-2006, 11:51 PM   #1
New Member
Thread Starter
 
Join Date: 06-05-05
Location: Farmington Hills, MI
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Turn Signal Problem?

The other day I got into my Cobalt for the first time in about a week, I drove it around and I was going to turn right onto an intersection. I had my radio on and I thought I heard a fast clicking noise. I looked down and my turn signal is blinking twice per second.

I do know that this is something that needs to be serviced, but has anyone else had this problem? And does anything affect it? The only thing I did was change my headlights and disconnect the battery when not driving because of the cold weather. Any advice would be greatly appreciated. Thanks!
JoeSS is offline   Reply With Quote
Old 01-28-2006, 11:54 PM   #2
Senior Member
 
Join Date: 06-05-05
Location: Fort Collins, CO
Posts: 2,303
Thanks: 0
Thanked 0 Times in 0 Posts
Sounds like either your front or rear turn signal bulb is burnt out or disconnected, go out and check it out.
Chevypowered is offline   Reply With Quote
Old 01-29-2006, 12:09 AM   #3
New Member
Thread Starter
 
Join Date: 06-05-05
Location: Farmington Hills, MI
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Checked them both out, all four lights work. Service manager doesn't know where it came from...
JoeSS is offline   Reply With Quote
Old 01-29-2006, 12:12 AM   #4
p7x
Senior Member
 
Join Date: 01-15-05
Location: Ottawa
Posts: 5,126
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 57
if it keeps doing it, change the bulb, if you havent already done so.
p7x is offline   Reply With Quote
Old 01-29-2006, 12:13 AM   #5
Senior Member
 
Join Date: 06-05-05
Location: Fort Collins, CO
Posts: 2,303
Thanks: 0
Thanked 0 Times in 0 Posts
Could be your turn signal relay that has gone bad, try swapping you relays and see if it happens on the other side
Chevypowered is offline   Reply With Quote
Old 01-29-2006, 12:19 AM   #6
New Member
Thread Starter
 
Join Date: 06-05-05
Location: Farmington Hills, MI
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
I think the relay for both my left and right signal is bad. When I turn on my hazards, which I know is a different relay, they work fine. But both of my signals flash extremely fast.
JoeSS is offline   Reply With Quote
Old 01-29-2006, 12:46 AM   #7
New Member
 
Join Date: 11-05-05
Location: howell
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
i had a problem with mine too but we found out that both tail light sockets were bad and that they had to order them, that sucks, also i lost all int. lights as well ever the guage lights. i have not had the car in 4 days, the reason its taking so long is the cant just order the sockets its got to be the whole tail light i hope i get it back on monday
tinyone is offline   Reply With Quote
Old 01-29-2006, 01:32 AM   #8
Premium Member
 
WopOnTour's Avatar
 
Join Date: 07-04-05
Location: No where man
Posts: 730
Thanks: 0
Thanked 0 Times in 0 Posts
Images: 5
Quote:
Originally Posted by Chevypowered
Could be your turn signal relay that has gone bad, try swapping you relays and see if it happens on the other side
Quote:
Originally Posted by JoeSS
I think the relay for both my left and right signal is bad. When I turn on my hazards, which I know is a different relay, they work fine. But both of my signals flash extremely fast.
There is NO turn signal relays or flasher for the Cobalt signal lights (or a great many other cars/trucks for that matter).
Basically the BCM controls the turn signal bulbs directly based on input from the turn signal and hazard switches. If you have GOOD STOCK PN# BULBS installed AND there are no blown fuses present in the fuse panel located on the RH side of your console (techncially a "smart" fuse panel aka the BCM!) Then you should take it in to your service dept as there are likely DTCs present in the BCM that will indicate what might be wrong.
WopOnTour
WopOnTour is offline   Reply With Quote
Old 02-04-2007, 02:09 PM   #9
Senior Member
 
Join Date: 12-15-06
Location: .
Posts: 618
Thanks: 0
Thanked 0 Times in 0 Posts
Mine just devloped the same problem, last night I switched my headlight bulbs.

Took it out fora drive to align the lights, used the turn signals.

Took it out the next morning, drive into down got luch, drove home. About 30 min drive time in town and I always use my signals. Pullin back on to my street make a right turn.

Got the fast click , figured that the bulb got shocked when I had the headlights out.

In the garage with the headlights on and parking lights on BOTH filiments in the passenger side turnsignal bulb are lit, no blinking. The driver side operating normaly.

Horay service department tommrow.
blktrax is offline   Reply With Quote
Old 02-05-2007, 10:22 PM   #10
Senior Member
 
Join Date: 12-15-06
Location: .
Posts: 618
Thanks: 0
Thanked 0 Times in 0 Posts
Well dealer ordered a BCM and a new headlight assembly for mine, we shall see if that fixes it.
blktrax is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New steering rack Solaris99 08-10 SS Turbocharged General Discussion 28 03-15-2017 01:22 PM
Akron/Canton Cobalt Meet 06MetallicBalt Mid East 7 06-14-2016 02:17 PM
Wideband o2 Stimulating Factory NB o2 Tupp 2.2L LAP Performance Tech 5 01-02-2016 12:04 PM
07 lsj-t problems gen 3 build Adiaz1ss Problems/Service/Maintenance 4 09-26-2015 11:51 PM
everytime i fill up my balt has trouble turning on roth Problems/Service/Maintenance 2 09-26-2015 12:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:29 PM.