p0451 - Cobalt SS Network

Problems/Service/Maintenance Do you have problems with your new 2.0, 2.2, or 2.4L? What kind of service did you have done?

p0451

Reply

 
 
 
Old 01-05-2017, 02:48 PM
  #1  
New Member
Thread Starter
 
bahoodle's Avatar
 
Join Date: 11-01-16
Location: Western NY
Posts: 134
Thanked 4 Times in 4 Posts
Exclamation p0451

so i had code p0451 for fuel tank pressure sensor range/ performance. i replaced the sensor and had the code cleared today but i gotta feeling the code'll come back :/ someone lmk if you've had this code and wat the definite fix is ;D i have no other codes wit it
bahoodle is offline  
Reply With Quote
Old 01-05-2017, 05:19 PM
  #2  
New Member
Thread Starter
 
bahoodle's Avatar
 
Join Date: 11-01-16
Location: Western NY
Posts: 134
Thanked 4 Times in 4 Posts
ill repost to this in a couple days if that was the fix for anyone whos got the code p0451
bahoodle is offline  
Reply With Quote
Old 01-09-2017, 08:27 PM
  #3  
New Member
Thread Starter
 
bahoodle's Avatar
 
Join Date: 11-01-16
Location: Western NY
Posts: 134
Thanked 4 Times in 4 Posts
Fixed!!!!
bahoodle is offline  
Reply With Quote
Old 10-10-2018, 03:26 PM
  #4  
New Member
 
Join Date: 10-10-18
Location: salt lake city
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Hey

Originally Posted by bahoodle View Post
Fixed!!!!

what did u do to fix it?
Tyler Johnson is offline  
Reply With Quote
Old 10-11-2018, 08:49 AM
  #5  
Moderator
Platinum Member
Moderator
iTrader: (3)
 
Join Date: 04-18-14
Location: El Paso, TX
Posts: 14,316
Thanked 419 Times in 394 Posts
In going to guess changing the sensor did the trick
Snail_SS is offline  
Reply With Quote
Old 10-11-2018, 11:50 AM
  #6  
HGT
Senior Member
 
HGT's Avatar
 
Join Date: 03-17-17
Location: Parker Colorado
Posts: 1,944
Thanked 90 Times in 86 Posts
Mine some how broke right off the evap tank.
HGT is offline  
Reply With Quote
Old 10-12-2018, 02:41 AM
  #7  
New Member
Thread Starter
 
bahoodle's Avatar
 
Join Date: 11-01-16
Location: Western NY
Posts: 134
Thanked 4 Times in 4 Posts
on my 08 ss it was the purge valve n on my 09 base model it was thefuel tank pressure sensor. mine also snapped off the charcoal canister lmao
bahoodle is offline  
Reply With Quote
Reply
 
 
 


Thread Tools
Search this Thread