2.0L LSJ Performance Tech 205hp Supercharged SS tuner version. 200 lb-ft of torque.

Anyone ever use

Old 10-09-2012, 10:52 PM
  #1  
Senior Member
Thread Starter
 
shsballa023's Avatar
 
Join Date: 11-25-07
Location: Iowa
Posts: 1,575
Likes: 0
Received 0 Likes on 0 Posts
Anyone ever use

Anyone ever use those radiator stop leak fluids? I used some today jus untill I get my new radiator. It's keeping the coolant level and I see no leak now. But my low coolant comes up on my dash every start but then goes away.

I'm curious if maybe the sensor is messed up now? Or something else.
shsballa023 is offline  
Old 10-09-2012, 11:00 PM
  #2  
Senior Member
iTrader: (1)
 
Join Date: 05-07-08
Location: Minnesota
Posts: 6,428
Likes: 0
Received 2 Likes on 1 Post
Sensor is in the tank in the engine bay. Level should be kept at about the line (which is about half). If there is that much in there then maybe the sensor is bad.

Do a FULL flush when you get the new radiator then see if the sensor still has problems.
nhanson is offline  
Old 10-10-2012, 12:19 AM
  #3  
Senior Member
Thread Starter
 
shsballa023's Avatar
 
Join Date: 11-25-07
Location: Iowa
Posts: 1,575
Likes: 0
Received 0 Likes on 0 Posts
Yup full flush was already accounted for when I get it. Thank you tho!
shsballa023 is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.