Problems/Service/Maintenance Do you have problems with your new 2.0, 2.2, or 2.4L? What kind of service did you have done?

08 cobalt ss turbo p0036 code

Old 12-31-2018, 12:50 AM
  #1  
New Member
Thread Starter
 
Join Date: 12-30-16
Location: Vancouver, BC, Canada
Posts: 15
Liked 0 Times in 0 Posts
08 cobalt ss turbo p0036 code

Hi all i have an 08 cobalt ss turbo with 95k miles. Was running fine a few weeks ago. I previously added a catless downpipe with no o2 sensor a year ago. But it still ran fine. A bit rough on startup but ran great when warm. Have a k&n intake so I get the p0100 code all the time. But a few days ago I got the p0036 plus p0300 ... p0301... p0304. So all 4 cylinders had misfires. I cleaned the maf with maf cleaner and the misfire seemed to go away but still the p0306 code. But no more cutting out or hesitation. I just drove it for 10 min. But will try longer run later. Is it the other O2 sensor near the turbo thats bad? It looks like a bitch to get it out. I wonder if I should also put back the 02 sensor in the catless downpipe if thats possible? Thanks!





chris604 is offline  
Old 01-07-2019, 01:45 PM
  #2  
New Member
Thread Starter
 
Join Date: 12-30-16
Location: Vancouver, BC, Canada
Posts: 15
Liked 0 Times in 0 Posts
Originally Posted by chris604 View Post
Hi all i have an 08 cobalt ss turbo with 95k miles. Was running fine a few weeks ago. I previously added a catless downpipe with no o2 sensor a year ago. But it still ran fine. A bit rough on startup but ran great when warm. Have a k&n intake so I get the p0100 code all the time. But a few days ago I got the p0036 plus p0300 ... p0301... p0304. So all 4 cylinders had misfires. I cleaned the maf with maf cleaner and the misfire seemed to go away but still the p0306 code. But no more cutting out or hesitation. I just drove it for 10 min. But will try longer run later. Is it the other O2 sensor near the turbo thats bad? It looks like a bitch to get it out. I wonder if I should also put back the 02 sensor in the catless downpipe if thats possible? Thanks!
P0036 was for the O2 sensor in the downpipe. P0030 was the O2 sensor by the turbo. Surprised that Im the only one to figure that out! So that wasnt it. Probably high pressure fuel pump or something like that? Only runs bad when warm. And cuts out under load at high RPM.
Throws codes p0036 and p0100 plus p030x for all 4 cylinders on an agressive tune instead of stock tune.
chris604 is offline  
Old 04-19-2019, 08:37 PM
  #3  
Member
 
Join Date: 06-18-12
Location: RGV, Texas
Posts: 230
Likes: 0
Liked 1 Time in 1 Post
Did you figure it put I'm having a similar issue
coolbalt1 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
VolklSkiier
Problems/Service/Maintenance
5
07-18-2016 11:27 PM
burlap1980
Problems/Service/Maintenance
21
03-19-2012 05:04 PM
johnladow07
2.0L LSJ Performance Tech
5
10-11-2010 09:47 PM
ovcuban
2.0L LSJ Performance Tech
11
08-06-2010 03:53 PM
brett5
Problems/Service/Maintenance
3
05-26-2010 08:25 PM


Thread Tools
Search this Thread
Quick Reply: 08 cobalt ss turbo p0036 code


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.