M62 help - Cobalt SS Network



Problems/Service/Maintenance Do you have problems with your new 2.0, 2.2, or 2.4L? What kind of service did you have done?

Reply
 
 
 
Thread Tools Search this Thread
Old 09-30-2015, 09:23 PM   #1
Member
Thread Starter
 
Join Date: 04-05-14
Location: lake village
Posts: 347
Thanks: 0
Thanked 1 Time in 1 Post
M62 help

So I'm hearing a type of rattling noise coming from the blower at idle. Not sure if it's the coupler or something more serious. Here's what it sounds like. https://youtu.be/Td7kK9BeMVY
Any input helps
jimbofug007 is offline   Reply With Quote
Old 09-30-2015, 11:33 PM   #2
Senior Member
 
Join Date: 06-06-06
Location: O Fallon, MO
Posts: 2,727
Thanks: 0
Thanked 8 Times in 7 Posts
The video is marked private so nobody can watch it.

If the noise sounds like a bunch of marbles rolling around then it is more than likely the coupler.
rnjmur is offline   Reply With Quote
Old 10-01-2015, 04:39 AM   #3
Member
Thread Starter
 
Join Date: 04-05-14
Location: lake village
Posts: 347
Thanks: 0
Thanked 1 Time in 1 Post
Ok I didn't realize I t was like that I changed it to public
jimbofug007 is offline   Reply With Quote
Old 10-01-2015, 07:19 AM   #4
Administrator
Administrator
Platinum Member
iTrader: (25)
 
Staged07SS's Avatar
 
Join Date: 12-30-07
Location: NEPA
Posts: 14,324
Thanked 189 Times in 167 Posts
coupler for sure.
Staged07SS is offline   Reply With Quote
Old 10-01-2015, 07:23 AM   #5
Member
Thread Starter
 
Join Date: 04-05-14
Location: lake village
Posts: 347
Thanks: 0
Thanked 1 Time in 1 Post
Quote:
Originally Posted by Staged07SS View Post
coupler for sure.
That's what I was thinking but I wanted to make sure.
jimbofug007 is offline   Reply With Quote
Old 10-01-2015, 11:03 PM   #6
Member
Thread Starter
 
Join Date: 04-05-14
Location: lake village
Posts: 347
Thanks: 0
Thanked 1 Time in 1 Post
Opened the blower to find this. Looks like I'll be needing another one. This is why you don't plug the silencer holes. Dumbest mod ever.
Attached Thumbnails
imag0995.jpg   imag0996.jpg   imag0994.jpg  
jimbofug007 is offline   Reply With Quote
Old 10-02-2015, 07:18 AM   #7
Administrator
Administrator
Platinum Member
iTrader: (25)
 
Staged07SS's Avatar
 
Join Date: 12-30-07
Location: NEPA
Posts: 14,324
Thanked 189 Times in 167 Posts
Quote:
Originally Posted by jimbofug007 View Post
Opened the blower to find this. Looks like I'll be needing another one. This is why you don't plug the silencer holes. Dumbest mod ever.
Thank you!!!! I warn people on here time and time again about how retarded it is to plug the silencer holes.

Such a useless mod for a bit of extra noise, and increased risk of ruining the blower.

ZZP sells brand new rotor packs fyi.
Staged07SS is offline   Reply With Quote
Old 10-02-2015, 12:06 PM   #8
Senior Member
iTrader: (3)
 
CobaltSS 16's Avatar
 
Join Date: 07-01-07
Location: NJ
Posts: 4,156
Thanked 29 Times in 25 Posts
Quote:
Originally Posted by jimbofug007 View Post
Opened the blower to find this. Looks like I'll be needing another one. This is why you don't plug the silencer holes. Dumbest mod ever.
I may have my ported m62 for sale soon. how fast do you need a blower?
CobaltSS 16 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
For Sale Supercharger parts and more Spanky's Monkey Parts 37 03-07-2016 06:06 PM
Buying a used blower DarrenGC Forced Induction 6 01-02-2016 09:10 PM
M62 spacer plate- zzp goaliemo 2.0L LSJ Performance Tech 6 09-28-2015 01:37 PM
A couple runs last night Builttss War Stories 5 09-22-2015 12:42 AM
TVS Install Question NOT MAP SENSOR RELATED RedLined 2.0L LSJ Performance Tech 2 09-09-2015 09:11 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:09 PM.