08-10 SS Turbocharged General Discussion Discuss the 2008 - 2009 Chevy Cobalt SS Turbocharged. On sale since the second quarter of 2008.

Charge Piping Came Loose.....

Old 03-24-2012, 08:27 PM
  #126  
Senior Member
 
IsItFast?'s Avatar
 
Join Date: 05-21-08
Location: Creedmoor, nc
Posts: 1,006
Likes: 0
Liked 0 Times in 0 Posts
Originally Posted by IsItFast? View Post
You dont need a tune - to realize the full potential you do. Anyway, I prefer to fix things right, especially on a brand new car. Whats your car going to look like in 10 years if you keep using zip ties and duct tape to fix it? No offense. (oh, and its at $349 now.)
Originally Posted by IsItFast? View Post
fix it permanently - Hahn has a group buy on his charge piping right now, looks like we have 20+ people for it (intercooler too). Or get TTR's.
You know, its funny. Looking back on posts I made when I first got the car compared to what I have learned since. I'm back to running stock charge pipes - I ripped all that hahn **** off my car about a year ago, put it back on recently and remembered why I removed it. I never got it to fit right, blew the pipes off more than once due to the "hahn recommended worm clamps, oh yeah they will hold just fine" (that wasnt an issue after going to tbolt clamps, but didnt fix the fitment issues)..

The last time I ripped the piping out I literally threw it across the garage. Its going in the trash this week, I won't even give that crap away. Even the powdercoat job (that I paid extra from hahn for) was beginning to bubble. The 3 ply couplers included in the kit were very short, just enough to get the job done, but were beginning to tear. The 45 degree one did eventually tear.
IsItFast? is offline  
Old 03-25-2012, 01:18 AM
  #127  
Senior Member
iTrader: (4)
 
Join Date: 05-26-09
Location: Calgary, Alberta
Posts: 13,456
Liked 12 Times in 9 Posts
^^ this plays into why I"m rolling with almost entirely OEM parts...
soundjunky is offline  
Old 05-15-2012, 03:45 AM
  #128  
New Member
iTrader: (1)
 
Join Date: 05-23-08
Location: Rosemount, MN
Posts: 105
Likes: 0
Liked 0 Times in 0 Posts
Not sure if this will get any attention in this thread but I'll try.

So my stock charge piping has popped off twice now. Right where it connects to the turbo.

The first time it happened was about 20 minutes after I installed my new downpipe too which made me think I had an exhaust leak or something (I don't know **** about cars lol). So I put the little hose thing back on, and tightened the clamp. Next day the thing pops off again??

I have a 2010. I thought this was fixed by then so what the ****?

And be nice, I'm mechanically illiterate

Last edited by xChase; 05-15-2012 at 05:06 AM.
xChase is offline  
Old 05-15-2012, 12:20 PM
  #129  
Senior Member
iTrader: (4)
 
Join Date: 05-26-09
Location: Calgary, Alberta
Posts: 13,456
Liked 12 Times in 9 Posts
NEVER had mine pop off...

*shrugs*

all 2010's would have the fix, which basically secured it to a bracket on the top of the engine...

*shrugs*
soundjunky is offline  
Old 08-14-2012, 06:06 PM
  #130  
New Member
 
Join Date: 08-14-12
Location: Columbus
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
it's a service update that needs to change the clips, if your car is still under warranty it's free
phaeton217 is offline  
Old 05-15-2013, 08:06 PM
  #131  
New Member
iTrader: (1)
 
Join Date: 07-01-12
Location: Windsor
Posts: 44
Likes: 0
Liked 0 Times in 0 Posts
My stock cp never blew off... I bought an upper cp from ZZP only blew off once in the year and a half I had it. Make sure you tighten it up after the motor gets warm a few times.
TurbaltSS_09 is offline  
Old 05-15-2013, 08:08 PM
  #132  
Senior Member
 
Join Date: 02-11-09
Location: Detroit, MI
Posts: 1,384
Likes: 0
Liked 0 Times in 0 Posts
When I was shopping for a SS/TC, all of the early 2009s had the stock charge piping come loose. I showed the salespeople this and pushed it back in place to show them. My 2009 was manufactured around early 2009 and had a revised clip. 4 years later, it is still in place.
metroplex is offline  
Old 05-16-2013, 08:58 PM
  #133  
Member
 
Join Date: 05-15-13
Location: Ottawa
Posts: 336
Likes: 0
Liked 0 Times in 0 Posts
I have hahn piping all around with a stage 1 and its awesome! Never any issues other than putting a dent in my hood. But i have a new hood now and no problems.
cfsnipers is offline  
Old 07-31-2013, 08:46 PM
  #134  
New Member
 
Join Date: 03-08-11
Location: Winnipeg, Manitoba
Posts: 9
Likes: 0
Liked 0 Times in 0 Posts
Have a 09 and my cp has blown off many times right where the pipe meets the top of the turbo. I brought it in for the warranty work and they didn't really do anything. So it happened again a little while after I brought it to the dealer, so he looked with me and tightened it while I was looking and he tightened it all the way down like I had. And it was warm so no more expanding was gonna happen. It worked well with no problems for a while.. Then boom! Again! So I keep a little ratchet and socket in my glove compartment just in case.
I saw the zip ties near the beginning of this thread but I'm sure that wont help tying down the middle of the pipe when it comes off right at the turbo. So what do I do to keep it clamped down. ....

Ps, I have a stock motor and everything. Car is bone stock.
09FullBoost is offline  
Old 08-01-2013, 10:21 AM
  #135  
Senior Member
iTrader: (4)
 
Join Date: 05-26-09
Location: Calgary, Alberta
Posts: 13,456
Liked 12 Times in 9 Posts
do you have the clip?
Is it retained in the location mentioned earlier?

if you don't, then the pipe is able to move - in order to come loose the whole pipe has to be able to move;
affixing the pipe midway limits the pipes' ability to move, and thereby eliminating this issue.

I have aprox 109,000km, and not once has my pipe come off ~ then again mine is a late '09 model year build - so it had the revised clip from the get-go.
soundjunky is offline  
Old 08-01-2013, 02:54 PM
  #136  
Member
 
Join Date: 04-23-12
Location: Edmonton, AB
Posts: 270
Likes: 0
Liked 0 Times in 0 Posts
I have the upper/lower pipes from ZZP, and when I put them on, I used tbolt clamps and cranked those ******* down hard. Ran the car for a couple months, and they were fine.. but then the weather started doing some funky things, and I was blowing the upper one off like every 3 days. Once it was teh coldest day out, I tightened it up with an impact drill, and ever since then, never had it come off.
PsychoGenius is offline  
Old 08-01-2013, 03:48 PM
  #137  
New Member
 
Join Date: 03-08-11
Location: Winnipeg, Manitoba
Posts: 9
Likes: 0
Liked 0 Times in 0 Posts
Soundjunkie What clip is this? Can u post a pic or something?

And yes the whole pipe moves
09FullBoost is offline  
Old 08-02-2013, 01:07 PM
  #138  
Senior Member
iTrader: (4)
 
Join Date: 05-26-09
Location: Calgary, Alberta
Posts: 13,456
Liked 12 Times in 9 Posts
Originally Posted by 09FullBoost View Post
Soundjunkie What clip is this? Can u post a pic or something?

And yes the whole pipe moves
please go back to the begining of this thread.
soundjunky is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
taintedred07
2.0L LNF Performance Tech
31
04-24-2016 12:10 PM
KMO43
Front Page News
34
01-12-2016 12:01 AM
717ssbalt
2.0L LNF Performance Tech
9
10-02-2015 04:01 PM
nathan112i
Featured Car Showcase
41
09-30-2015 07:12 PM
KMO43
Featured Car Showcase
37
09-27-2015 08:53 PM


Thread Tools
Search this Thread
Quick Reply: Charge Piping Came Loose.....


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.