2.0L LNF Performance Tech 260hp and 260 lb-ft of torque Turbocharged tuner version.

Issues with LNF with Vac and random KR

Old 09-29-2015, 02:25 AM
  #1  
Senior Member
Thread Starter
 
Join Date: 04-27-13
Location: Arizona
Posts: 1,555
Received 19 Likes on 19 Posts
Unhappy Issues with LNF with Vac and random KR

So for the past week the car has been having an ANNOYING amount of KR in every gear but not at WOT. In first it's been showing 11.9 kr 2nd 8-12kr 3rd 3-9 and so on. I've also had the vac never go to 20-22 it's always been at 18-20 since the new engine was put in. Currently on full E for 2 weeks before it started happening, didn't put new seals in stock injectors, ZZP LNF fuel lobe cam is in.

My tuner suggested rotate and re torque knock sensor and I suggested to switch injectors with my brother's old injectors laying around. Rail pressure at WOT is 2300-2450 till 6600, never logged above that.

I've tried disconnecting the battery for a couple of min, clearing DTC's when there's none, disconnecting EVAP solenoid, and it did run PERFECT for 1 night for like 2 hours until the next morning then it started running like crap again. That was with only disconnecting the battery.

On the aeroforce gauge I have it shows a max KPA of 255 at wot which is weird, it also shows 22.7 PSI at wot but my factory boost gauge says 25 PSI.

If you need logs I can get with my tuner and get some. In the mean time I will swap injectors and rotate those knock sensors.
Sl0wbaltSS is offline  
Old 09-29-2015, 09:26 PM
  #2  
Senior Member
iTrader: (1)
 
kzak104's Avatar
 
Join Date: 03-18-12
Location: Langley, BC
Posts: 1,894
Likes: 0
Received 0 Likes on 0 Posts
the interceptors pin at 22.7psi for some reason, dont read boost off them, and did you get a bad batch of gas possibly
kzak104 is offline  
Old 09-29-2015, 10:23 PM
  #3  
Senior Member
iTrader: (6)
 
Join Date: 07-19-10
Location: Denver, Colorado
Posts: 22,637
Received 389 Likes on 346 Posts
What are your fuel trims? Difference in commanded lambda and actual lambda? What timing advance is it calling for in the tune file vs observed? And what is your injector ms?
ECaulk is offline  
Old 09-29-2015, 10:39 PM
  #4  
Senior Member
Thread Starter
 
Join Date: 04-27-13
Location: Arizona
Posts: 1,555
Received 19 Likes on 19 Posts
Originally Posted by ECaulk View Post
What are your fuel trims? Difference in commanded lambda and actual lambda? What timing advance is it calling for in the tune file vs observed? And what is your injector ms?
I would have to log that stuff. Fuel trims are within 2% positive for LTFT.
Sl0wbaltSS is offline  
Old 09-29-2015, 11:15 PM
  #5  
Senior Member
iTrader: (6)
 
Join Date: 07-19-10
Location: Denver, Colorado
Posts: 22,637
Received 389 Likes on 346 Posts
Stft matters a little more for KR
ECaulk is offline  
Old 09-29-2015, 11:16 PM
  #6  
Senior Member
iTrader: (6)
 
Join Date: 07-19-10
Location: Denver, Colorado
Posts: 22,637
Received 389 Likes on 346 Posts
I also hope your tuner is logging those parameters or you're close to a new engine
ECaulk is offline  
Old 09-29-2015, 11:18 PM
  #7  
Senior Member
 
Join Date: 12-11-13
Location: british columbia
Posts: 807
Received 11 Likes on 11 Posts
good, now do a log and look at this things ecaulk told you to look at but this time look at stft
nathan112i is offline  
Old 09-30-2015, 01:44 AM
  #8  
Senior Member
Thread Starter
 
Join Date: 04-27-13
Location: Arizona
Posts: 1,555
Received 19 Likes on 19 Posts
Originally Posted by nathan112i View Post
good, now do a log and look at this things ecaulk told you to look at but this time look at stft
I'll look at my stft and KR at the same time on my aeroforce. Can't log to prob friday.
Sl0wbaltSS is offline  
Old 09-30-2015, 12:39 PM
  #9  
Senior Member
 
Join Date: 05-20-06
Location: Phoenix, AZ
Posts: 6,913
Likes: 0
Received 4 Likes on 4 Posts
We will take a look at another log if you guys want. We scanned it again on Saturday, and his knock sensors are definitely logging feedback, but the car I am not detecting any real knock. I suggested the rotation and re-torquing of the knock sensors due to that helping some people with false knock issues. The most notable issue is that his car (exhaust, etc) rattles badly, so he has some contact somewhere that could now be passing along the vibration to these sensors. He is getting high amounts of feedback on both knock sensors at the moment.

When we initially spent 2 sessions tuning the car there was no knock what so ever, not even the feedback that he is now getting. On Saturday when we looked back over the car, he would have pretty much anywhere from 8-11.9 degrees of KR just cruising and then it would go away at WOT. I am very inclined to think that the metal on metal contact is less severe during WOT. I am nearly convinced that the rattling of metal on metal contact on his car is causing the reading.

There are some other suggestions I made for him as far as upgrading his injectors, so that we would not be so limited on fuel delivery, but that wouldn't be a cause for knock unless somehow his injector seals disappeared on his current injectors. We aren't hearing any popcorn noises that typically are described when injector seals fail, so he's probably alrught for now in that department.
Psykostevo is offline  
Old 09-30-2015, 12:42 PM
  #10  
Senior Member
 
Join Date: 05-20-06
Location: Phoenix, AZ
Posts: 6,913
Likes: 0
Received 4 Likes on 4 Posts
From logs during 2nd tuning session.

Injector MS



STFT



Knock Retard

Psykostevo is offline  
Old 09-30-2015, 12:46 PM
  #11  
Senior Member
iTrader: (6)
 
Join Date: 07-19-10
Location: Denver, Colorado
Posts: 22,637
Received 389 Likes on 346 Posts
I'm assuming those are the averages?

We really need to see whats going on at the point the knock is registering, not averaged values after the fact.
ECaulk is offline  
Old 09-30-2015, 12:57 PM
  #12  
Senior Member
 
Join Date: 05-20-06
Location: Phoenix, AZ
Posts: 6,913
Likes: 0
Received 4 Likes on 4 Posts
I will have to pull you logs of his current situation. Right now when it's in gear it just registers knock sensor data in basically every idle or cruising cell, average values and all.

Jacob, any luck on getting your pipes to stop rattling on the car?
Psykostevo is offline  
Old 09-30-2015, 10:27 PM
  #13  
Senior Member
Thread Starter
 
Join Date: 04-27-13
Location: Arizona
Posts: 1,555
Received 19 Likes on 19 Posts
Originally Posted by Psykostevo View Post
I will have to pull you logs of his current situation. Right now when it's in gear it just registers knock sensor data in basically every idle or cruising cell, average values and all.

Jacob, any luck on getting your pipes to stop rattling on the car?
Haven't gotten to it, had a graveyard shift and worked 10 hours. Tired and don't really wanna use a crappy tool to losen them and put them back in lol. Will work on tomorrow though.
Sl0wbaltSS is offline  
Old 10-03-2015, 10:47 AM
  #14  
Senior Member
Thread Starter
 
Join Date: 04-27-13
Location: Arizona
Posts: 1,555
Received 19 Likes on 19 Posts
Bumpity bump bump.
Sl0wbaltSS is offline  
Old 02-05-2016, 01:01 AM
  #15  
Senior Member
Thread Starter
 
Join Date: 04-27-13
Location: Arizona
Posts: 1,555
Received 19 Likes on 19 Posts
bump
Sl0wbaltSS is offline  
Old 02-05-2016, 11:11 PM
  #16  
Junior Member
iTrader: (2)
 
Join Date: 10-11-15
Location: Seattle, WA area
Posts: 415
Received 11 Likes on 11 Posts
Your tuner says your exhaust rattles like crazy.

You can't sit there and try to troubleshoot KR when you have crap rattling all over your drive train causing potential fake KR.

My car will go crazy with what I determined to be false KR. I have never seen it actually pull any timing in my logs when it registers KR.

I will get it off idle when i'm just lightly accelerating and it will go away completely if I get on it.

Recently I noticed at a certain RPM when the car is warming up I can hear something under the car vibrating *heat shield I presume* and am also going to assume that very well be the trigger of my false KR I register.

You said your exhaust is rattling like crazy. That's the #1 thing to fix.

You can't do much until you fix it.
firehawk618 is offline  
Old 11-17-2016, 12:00 PM
  #17  
Senior Member
 
Join Date: 02-28-10
Location: Burlington, Ontario
Posts: 761
Received 17 Likes on 16 Posts
uh sorry for the thread revival but when did the former scion guy get banned?
his advice use to be good for a laugh at least lol
Dutchman is offline  
Old 11-17-2016, 12:59 PM
  #18  
Administrator
Administrator
Platinum Member
iTrader: (25)
 
Staged07SS's Avatar
 
Join Date: 12-30-07
Location: NEPA
Posts: 14,331
Received 191 Likes on 169 Posts
Originally Posted by Dutchman View Post
uh sorry for the thread revival but when did the former scion guy get banned?
his advice use to be good for a laugh at least lol
I banned him Monday after complaints. He is not perma banned yet, and will be back in a month. Hopefully he grows up some in that time.
Staged07SS is offline  
Old 11-21-2018, 11:11 PM
  #19  
Moderator
Platinum Member
Moderator
iTrader: (3)
 
Join Date: 04-18-14
Location: El Paso, TX
Posts: 15,048
Received 446 Likes on 420 Posts
Bump because I will need this info
Snail_SS is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
taintedred07
2.0L LNF Performance Tech
31
04-24-2016 12:10 PM
Zharrington_2010LNF
2.0L LNF Performance Tech
21
02-08-2016 01:43 PM
HEATON
Parts
12
10-16-2015 07:21 PM
Jesse
Parts
15
10-13-2015 09:32 PM
jmelton327
Drivetrain
2
09-26-2015 10:04 PM


Thread Tools
Search this Thread
Quick Reply: Issues with LNF with Vac and random KR


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.