Problems/Service/Maintenance Do you have problems with your new 2.0, 2.2, or 2.4L? What kind of service did you have done?

Great...2 CEL codes now

Old 10-22-2005, 03:13 AM
  #1  
Senior Member
Thread Starter
 
Tofu's Avatar
 
Join Date: 07-11-05
Location: Houston
Posts: 2,533
Likes: 0
Liked 0 Times in 0 Posts
Great...2 CEL codes now

Just got back from a meet here in Houston, first time since I've gotten my K&N that i've been putting her under load consistantly for a few hours cruising around and stuff. Anyway, just as I was pulling up a few minutes ago my CEL came on. Luckily my buddy works for Chrylser and had his DRBIII or V or whatever scan tool. Anyway I was too lazy and tired to take down the codes, but one was the "engine running lean" code and "PCM internal malfunction"...WTF. Anyone ever gotten this code before?

Needless to say this really sucks, I popped the hood briefly to check out the hose clamps from the TB to the intake tube were tight and they checked out alright. I guess I'll have to inspect the rest of it tomorrow....ugh. Hopefully the folks @ MP can help me out, or I'll call K&N get some ideas. I did everything by the book, disconnected the battery, used the MAF screws etc. etc. And as far as the PCM, I have no clue..I guess I'll have to take her in to the dealership for the 1000 time.
Tofu is offline  
Old 10-22-2005, 10:27 AM
  #2  
Member
 
Join Date: 08-05-04
Location: New Jersey
Posts: 354
Likes: 0
Liked 0 Times in 0 Posts
sorry to hear that man. i was just about to go out and look at my car. now I don't know if I even wanna bother. there goes another non cel person.
Maverick is offline  
Old 10-22-2005, 10:38 AM
  #3  
Banned
 
Join Date: 03-30-05
Posts: 6,981
Likes: 0
Liked 0 Times in 0 Posts
wow that sucks. I hope they go away I think my meet today with a few members will showcase me being the only one out of the group that doesn't get a CEL on K&N intake and Catback exhaust
3fo893013L is offline  
Old 10-22-2005, 11:29 AM
  #4  
Member
 
Join Date: 09-25-05
Location: Doylestown PA
Posts: 265
Likes: 0
Liked 0 Times in 0 Posts
Originally Posted by sneaky
wow that sucks. I hope they go away I think my meet today with a few members will showcase me being the only one out of the group that doesn't get a CEL on K&N intake and Catback exhaust
Did you install them at the same time.
Joe
JAESS is offline  
Old 10-22-2005, 11:44 AM
  #5  
LSX RWD S/C conversion
iTrader: (2)
 
victory_red_SS's Avatar
 
Join Date: 03-25-05
Location: Maple Ridge, BC, Canada
Posts: 9,586
Liked 10 Times in 8 Posts
For everyone who installed their K&N intakes you likely did everything right. The dealership got the same results when they installed mine.
As for K&N goes, I expect they will soon say that it is all of our fault for bugging them so much for this intake that they had to rush to meet demand
victory_red_SS is offline  
Old 10-22-2005, 11:53 AM
  #6  
Member
 
Join Date: 08-05-04
Location: New Jersey
Posts: 354
Likes: 0
Liked 0 Times in 0 Posts
Originally Posted by victory_red_SS
For everyone who installed their K&N intakes you likely did everything right. The dealership got the same results when they installed mine.
As for K&N goes, I expect they will soon say that it is all of our fault for bugging them so much for this intake that they had to rush to meet demand
so what is the dealership doing with it now?
Maverick is offline  
Old 10-22-2005, 05:38 PM
  #7  
New Member
 
Join Date: 08-01-05
Location: Minnesota
Posts: 61
Likes: 0
Liked 0 Times in 0 Posts
Installed my K&N last night. CEL didn't turn on last night, but did this morning on my way to work. I didn't unplug the battery cause people on here and .com were saying that they didn't get a code doing it that way. Guess that doesn't matter.

How tight did you guys screw the MAF screws in?

Oldbenwa
oldbenwa is offline  
Old 10-23-2005, 12:43 AM
  #8  
Member
 
Join Date: 08-05-04
Location: New Jersey
Posts: 354
Likes: 0
Liked 0 Times in 0 Posts
I screwed the maf screws in pretty tightly. although i didn't pay much attention to the supposed 'ring' thats on it. so maybe i'll make sure thats centered.
Maverick is offline  
Old 10-23-2005, 08:29 AM
  #9  
LSX RWD S/C conversion
iTrader: (2)
 
victory_red_SS's Avatar
 
Join Date: 03-25-05
Location: Maple Ridge, BC, Canada
Posts: 9,586
Liked 10 Times in 8 Posts
Originally Posted by Maverick
so what is the dealership doing with it now?
after it came on again I haven't been able to see the dealership yet. Now I am finding that the light comes and goes when it feels like.
victory_red_SS is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
turbochargedss2012
2.0L LNF Performance Tech
7
03-20-2016 12:30 AM
ernnyyes
Problems/Service/Maintenance
5
10-02-2015 05:16 PM
Extremespeed
South Pacific
0
09-29-2015 04:34 AM
DocSvensk
2.0L LNF Performance Tech
7
09-27-2015 02:24 PM
OrangeCoba
Problems/Service/Maintenance
0
09-25-2015 06:06 PM


Thread Tools
Search this Thread
Quick Reply: Great...2 CEL codes now


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.